How to get SPI1 working with 4.1 Kernel when mcasp is preventing the pins to be configured correctly

After I have enabled SPI1 using the SPI overlay everything seems to be configured correctly. However when I check the pins to see if they are in the correct mode, they are still configured for gpio. I run dmesg and it outputs that these pins are already requested by mcasp.

my config for the 4.1 kernel in the /boot/uEnv.txt file is:

##Example v4.1.x
cape_disable=bone_capemgr.disable_partno=BB-SPIDEV0,BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G
cape_enable=bone_capemgr.enable_partno=BB-I2C1,BB-CAN1,BB-SPIDEV1

when i run the command ‘ls -la /dev/spi*’ it show the following:

crw-rw---- 1 root spi 153, 1 Jul 21 17:18 /dev/spidev1.0
crw-rw---- 1 root spi 153, 0 Jul 21 17:18 /dev/spidev1.1

However the pins are still configured to be gpio:

root@beaglebone:/sys/kernel/debug/pinctrl/44e10800.pinmux# more pins

pin 100 (44e10990.0) 00000027 pinctrl-single

pin 101 (44e10994.0) 00000027 pinctrl-single

pin 102 (44e10998.0) 00000027 pinctrl-single

pin 103 (44e1099c.0) 00000027 pinctrl-single

but…
root@beaglebone:~# cat /sys/devices/platform/bone_capemgr/slots
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,BB-I2C1
5: P-O-L- 1 Override Board Name,00A0,Override Manuf,BB-CAN1
6: P-O-L- 2 Override Board Name,00A0,Override Manuf,BB-SPIDEV1

Also, when i run dmesg i get:

root@beaglebone:~# dmesg | grep spi
[ 18.526603] pinctrl-single 44e10800.pinmux: pin 44e10990.0 already requested by 48038000.mcasp; cannot claim for 481a0000.spi
[ 19.028093] pinctrl-single 44e10800.pinmux: pin-100 (481a0000.spi) status -22
[ 19.162354] pinctrl-single 44e10800.pinmux: could not request pin 100 (44e10990.0) from group pinmux_bb_spi1_pins on device pinctrl-single
[ 20.010557] omap2_mcspi 481a0000.spi: Error applying setting, reverse things back

How do i get SPI1 to work? Any help is appreciated, thanks.

After I have enabled SPI1 using the SPI overlay everything seems to be
configured correctly. However when I check the pins to see if they are in
the correct mode, they are still configured for gpio. I run dmesg and it
outputs that these pins are already requested by mcasp.

my config for the 4.1 kernel in the /boot/uEnv.txt file is:

##Example v4.1.x
cape_disable=bone_capemgr.disable_partno=BB-SPIDEV0,BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G
cape_enable=bone_capemgr.enable_partno=BB-I2C1,BB-CAN1,BB-SPIDEV1

when i run the command 'ls -la /dev/spi*' it show the following:

crw-rw---- 1 root spi 153, 1 Jul 21 17:18 /dev/spidev1.0
crw-rw---- 1 root spi 153, 0 Jul 21 17:18 /dev/spidev1.1

However the pins are still configured to be gpio:

root@beaglebone:/sys/kernel/debug/pinctrl/44e10800.pinmux# more pins

...

pin 100 (44e10990.0) 00000027 pinctrl-single
pin 101 (44e10994.0) 00000027 pinctrl-single
pin 102 (44e10998.0) 00000027 pinctrl-single
pin 103 (44e1099c.0) 00000027 pinctrl-single

...

but...
root@beaglebone:~# cat /sys/devices/platform/bone_capemgr/slots
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,BB-I2C1
5: P-O-L- 1 Override Board Name,00A0,Override Manuf,BB-CAN1
6: P-O-L- 2 Override Board Name,00A0,Override Manuf,BB-SPIDEV1

Also, when i run dmesg i get:

root@beaglebone:~# dmesg | grep spi
[ 18.526603] pinctrl-single 44e10800.pinmux: pin 44e10990.0 already
requested by 48038000.mcasp; cannot claim for 481a0000.spi
[ 19.028093] pinctrl-single 44e10800.pinmux: pin-100 (481a0000.spi) status
-22
[ 19.162354] pinctrl-single 44e10800.pinmux: could not request pin 100
(44e10990.0) from group pinmux_bb_spi1_pins on device pinctrl-single
[ 20.010557] omap2_mcspi 481a0000.spi: Error applying setting, reverse
things back

mcasp = hdmi audio...

Since you want:

cape_disable=bone_capemgr.disable_partno=BB-SPIDEV0,BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G

set:

dtb=am335x-boneblack-overlay.dtb

in /boot/uEnv.txt

Regards,

after uncommenting the line:
#dtb=am335x-boneblack-overlay.dtb

…my beaglebone has trouble loading the kernel and drops to a shell. i’ve managed to record the debug output from uart0:

Starting kernel …

[ 0.000453] WARNING: Your ‘console=ttyO0’ has been replaced by 'ttyS0’
[ 0.000463] This ensures that you still see kernel messages. Please
[ 0.000471] update your kernel commandline.
[ 3.554658] omap_voltage_late_init: Voltage driver support not added
[ 3.676455] bone_capemgr bone_capemgr: slot #0: No cape found
[ 3.736442] bone_capemgr bone_capemgr: slot #1: No cape found
[ 3.796440] bone_capemgr bone_capemgr: slot #2: No cape found
[ 3.856434] bone_capemgr bone_capemgr: slot #3: No cape found
Loading, please wait…
Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
- Check rootdelay= (did the system wait long enough?)
- Check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/4ccbfb5c-9e82-4bed-aa38-a0d7a10e2404 does not exist. Dropping to a shell!
(initramfs) cat /proc/cmdline
console=ttyO0,115200n8 bone_capemgr.enable_partno=BB-I2C1,BB-CAN1,BB-SPIDEV1 root=UUID=4ccbfb5c-9e82-4bed-aa38-a0d7a10e2404 ro rootfstype=ext4 rootwait fixrtc coherent_pool=1M quiet

Are you using the eMMC?

dtb=am335x-boneblack-emmc-overlay.dtb

(it was just recently added, so your kernel might not have it yet)

Regards,

I did git pull from your dtb-rebuilder repository to get your latest updates and i recompiled to get the am335x-boneblack-emmc-overlay.dtb copied to my /boot/dtbs/4.4.1-ti-r2 folder.

I did change the contents of the uEnv file to: dtb=am335x-boneblack-emmc-overlay.dtb

i rebooted and no hang time which is good but now the cape manager is failing to load. So i went ahead and commented out the line:
#dtb=am335x-boneblack-emmc-overlay.dtb
and restarted the system to see if the emmc-overlay was the issue. After reboot there’s still an error with the cape manager at boot. So im confronted with an entirely different issue. i have set

cape_enable=bone_capemgr.enable_partno=BB-I2C1,BB-SPIDEV1

but spi1 nor i2c1 is enabled:

ls: cannot access /dev/spi*: No such file or directory

root@beaglebone:/boot/dtbs# li2c

lrwxrwxrwx 1 root root 0 Jul 22 19:32 /sys/bus/i2c/devices/i2c-0 → …/…/…/devices/platform/ocp/44e0b000.i2c/i2c-0

lrwxrwxrwx 1 root root 0 Jul 22 19:32 /sys/bus/i2c/devices/i2c-2 → …/…/…/devices/platform/ocp/4819c000.i2c/i2c-2

also dmeg outputs:

root@beaglebone:/boot/dtbs# dmesg | grep cape
[ 0.000000] Kernel command line: console=ttyO0,115200n8 bone_capemgr.enable_partno=BB-I2C1,BB-SPIDEV1 root=UUID=14cc3e93-25d2-4555-9daa-613112047ac1 ro rootfstype=ext4 rootwait fixrtc coherent_pool=1M quiet
[ 3.331315] bone_capemgr bone_capemgr: Failed to get baseboard eeprom cell
[ 3.338374] bone_capemgr: probe of bone_capemgr failed with error -2

I’m not sure what to do to fix this…any suggestions, thanks RCNelson for the help so far?

Update: setting “dtb=am335x-boneblack-emmc-overlay.dtb” in /boot/Env.txt solved the issue after updating to the “4.1.2-ti-r4” kernel image. Thanks for the help!

Hello,

I’ m currently facing the same issue with the SPI1. However, even with your solution, it is not working.

`

uname -ra

Linux beagle01 4.1.18-bone20 #4 Fri Mar 18 15:16:19 CET 2016 armv7l GNU/Linux

`

`

lsb_release -da

Distributor ID: Debian
Description: Debian GNU/Linux 8.3 (jessie)
Release: 8.3
Codename: jessie

`

`

cat $SLOTS

0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,BB-SPIDEV1

`

`

cat $PINS | grep ‘990|998|994|99c|97c’

pin 95 (44e1097c.0) 00000033 pinctrl-single
pin 100 (44e10990.0) 00000027 pinctrl-single
pin 101 (44e10994.0) 00000027 pinctrl-single
pin 102 (44e10998.0) 00000027 pinctrl-single
pin 103 (44e1099c.0) 00000027 pinctrl-single

`

`

cat /boot/uEnv.txt

uname_r=4.1.18-bone20
dtb=am335x-boneblack-overlay.dtb
cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G
cape_enable=bone_capemgr.enable_partno=BB-SPIDEV1
`

`

dmesg |grep SPI

[ 0.000000] Kernel command line: console=ttyO0,115200n8 capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G bone_capemgr.enable_partno=BB-SPIDEV1 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait
[ 4.618372] bone_capemgr bone_capemgr: enabled_partno PARTNO ‘BB-SPIDEV1’ VER ‘N/A’ PR ‘0’
[ 4.639023] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,BB-SPIDEV1’
[ 4.655351] bone_capemgr bone_capemgr: slot #4: dtbo ‘BB-SPIDEV1-00A0.dtbo’ loaded; overlay id #0

`

`

ls -la /dev/spi*

crw-rw---- 1 root spi 153, 0 Mar 25 14:17 /dev/spidev2.0
crw-rw---- 1 root spi 153, 1 Mar 25 14:17 /dev/spidev2.1

`

`

dmesg |grep cape

[ 0.000000] Kernel command line: console=ttyO0,115200n8 capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G bone_capemgr.enable_partno=BB-SPIDEV1 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait
[ 4.359224] bone_capemgr bone_capemgr: Baseboard: ‘A335BNLT,00C0,4414BBBK9699’
[ 4.366514] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4
[ 4.432592] bone_capemgr bone_capemgr: slot #0: No cape found
[ 4.492588] bone_capemgr bone_capemgr: slot #1: No cape found
[ 4.552588] bone_capemgr bone_capemgr: slot #2: No cape found
[ 4.612588] bone_capemgr bone_capemgr: slot #3: No cape found
[ 4.618372] bone_capemgr bone_capemgr: enabled_partno PARTNO ‘BB-SPIDEV1’ VER ‘N/A’ PR ‘0’
[ 4.626683] bone_capemgr bone_capemgr: slot #4: override
[ 4.632019] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[ 4.639023] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,BB-SPIDEV1’
[ 4.648433] bone_capemgr bone_capemgr: initialized OK.
[ 4.655351] bone_capemgr bone_capemgr: slot #4: dtbo ‘BB-SPIDEV1-00A0.dtbo’ loaded; overlay id #0

`

In addition, I’m not currently using the eMMC.
So, I don’t really understand what I’m doing wrong.
It looks like for me that it is an issue with the HDMI audio (mcasp), but I don’t see what I can do.
Is it because of the kernel version? Or is it something else?
If someone have any suggestions.

Thanks by advance
Regards
Vincent

Hello,

I' m currently facing the same issue with the SPI1. However, even with your
solution, it is not working.

# uname -ra
Linux beagle01 4.1.18-bone20 #4 Fri Mar 18 15:16:19 CET 2016 armv7l
GNU/Linux

# lsb_release -da
Distributor ID: Debian
Description: Debian GNU/Linux 8.3 (jessie)
Release: 8.3
Codename: jessie

# cat $SLOTS
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,BB-SPIDEV1

# cat $PINS | grep '990\|998\|994\|99c\|97c'
pin 95 (44e1097c.0) 00000033 pinctrl-single
pin 100 (44e10990.0) 00000027 pinctrl-single
pin 101 (44e10994.0) 00000027 pinctrl-single
pin 102 (44e10998.0) 00000027 pinctrl-single
pin 103 (44e1099c.0) 00000027 pinctrl-single

ignore that..

# cat /boot/uEnv.txt
uname_r=4.1.18-bone20
dtb=am335x-boneblack-overlay.dtb
cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G
cape_enable=bone_capemgr.enable_partno=BB-SPIDEV1

remove "cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G"
it's not used with "4.1.x"..

# dmesg |grep SPI
[ 0.000000] Kernel command line: console=ttyO0,115200n8
capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G
bone_capemgr.enable_partno=BB-SPIDEV1 root=/dev/mmcblk0p1 ro rootfstype=ext4
rootwait
[ 4.618372] bone_capemgr bone_capemgr: enabled_partno PARTNO 'BB-SPIDEV1'
VER 'N/A' PR '0'
[ 4.639023] bone_capemgr bone_capemgr: slot #4: 'Override Board
Name,00A0,Override Manuf,BB-SPIDEV1'
[ 4.655351] bone_capemgr bone_capemgr: slot #4: dtbo
'BB-SPIDEV1-00A0.dtbo' loaded; overlay id #0

# ls -la /dev/spi*
crw-rw---- 1 root spi 153, 0 Mar 25 14:17 /dev/spidev2.0
crw-rw---- 1 root spi 153, 1 Mar 25 14:17 /dev/spidev2.1

it's loaded, have you actually wired something up to it and tested?

Regards,

Thank for this quick answer,

So I have remove the line cape_disable=capemgr.disable_
partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G

In addition yes I have connected the PIN P9_29 (spi1_d0) and P9_30 (spi_d1)
And I'm trying to use the derek molloy program :
https://github.com/derekmolloy/exploringBB/tree/master/chp08/spi/spidev_test

./spidev_test -D /dev/spidev2.1

and also

./spidev_test -D /dev/spidev2.0

However I'm alway having the answer :
spi mode: 0
bits per word: 8
max speed: 500000 Hz (500 KHz)

00 00 00 00 00 00
00 00 00 00 00 00
00 00 00 00 00 00
00 00 00 00 00 00
00 00 00 00 00 00
00 00 00 00 00 00
00 00

And I'm supposed to received
bits per word: 8
max speed: 500000 Hz (500 KHz)

FF FF FF FF FF FF
40 00 00 00 00 95
FF FF FF FF FF FF
FF FF FF FF FF FF
FF FF FF FF FF FF
DE AD BE EF BA AD
F0 0D
I received this when I do that with SPI0 and connected P9_18(spi0_d0) and
P9_21(spi0_d1)

So I still don't get where did the problem come.

Compare your cape dts with:

https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-SPIDEV1-00A0.dts

Regards,

I tried directly by copying and past this one, and I had still the same answer. In addition I have tried to monitor the different signal on the scope, nothing.
Moreover, nothing new appears on the dmesg.

`

dmesg |tail

[ 18.828229] using random self ethernet address
[ 18.832790] using random host ethernet address
[ 18.837256] using host ethernet address: D0:39:72:31:1D:3B
[ 18.842633] using self ethernet address: D0:39:72:31:1D:30
[ 18.886570] usb0: HOST MAC d0:39:72:31:1d:3b
[ 18.909174] usb0: MAC d0:39:72:31:1d:30
[ 18.921832] using random self ethernet address
[ 18.926391] using random host ethernet address
[ 18.983303] g_ether gadget: Ethernet Gadget, version: Memorial Day 2008
[ 18.990066] g_ether gadget: g_ether ready
root@beagle01:~/labs/exploringBB/chp08/spi/spidev_test# dmesg | grep SPI
[ 0.000000] Kernel command line: console=ttyO0,115200n8 bone_capemgr.enable_partno=BB-SPIDEV1 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait
[ 4.608333] bone_capemgr bone_capemgr: enabled_partno PARTNO ‘BB-SPIDEV1’ VER ‘N/A’ PR ‘0’
[ 4.628986] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,BB-SPIDEV1’
[ 4.645313] bone_capemgr bone_capemgr: slot #4: dtbo ‘BB-SPIDEV1-00A0.dtbo’ loaded; overlay id #0

`

Yeah, double check your wires, it works as-is...

root@beaglebone:~# ./spidev_test -D /dev/spidev2.1
spi mode: 0
bits per word: 8
max speed: 500000 Hz (500 KHz)

FF FF FF FF FF FF
40 00 00 00 00 95
FF FF FF FF FF FF
FF FF FF FF FF FF
FF FF FF FF FF FF
DE AD BE EF BA AD
F0 0D
root@beaglebone:~# ./spidev_test -D /dev/spidev2.0
spi mode: 0
bits per word: 8
max speed: 500000 Hz (500 KHz)

FF FF FF FF FF FF
40 00 00 00 00 95
FF FF FF FF FF FF
FF FF FF FF FF FF
FF FF FF FF FF FF
DE AD BE EF BA AD
F0 0D

root@beaglebone:~# cat /proc/cmdline
console=tty0 console=ttyO0,115200n8
bone_capemgr.enable_partno=BB-SPIDEV1 root=/dev/mmcblk0p1
rootfstype=ext4 rootwait coherent_pool=1M quiet cape_universal=enable
root@beaglebone:~# uname -r
4.1.18-ti-r55

root@beaglebone:~# dmesg | grep bone
[ 0.000000] Kernel command line: console=tty0
console=ttyO0,115200n8 bone_capemgr.enable_partno=BB-SPIDEV1
root=/dev/mmcblk0p1 rootfstype=ext4 rootwait coherent_pool=1M quiet
cape_universal=enable
[ 3.426727] bone_capemgr bone_capemgr: Baseboard: 'A335BNLT, ,BBG115096609'
[ 3.426755] bone_capemgr bone_capemgr:
compatible-baseboard=ti,beaglebone-black - #slots=4
[ 3.477193] bone_capemgr bone_capemgr: slot #0: No cape found
[ 3.537209] bone_capemgr bone_capemgr: slot #1: No cape found
[ 3.597174] bone_capemgr bone_capemgr: slot #2: No cape found
[ 3.657179] bone_capemgr bone_capemgr: slot #3: No cape found
[ 3.662979] bone_capemgr bone_capemgr: enabled_partno PARTNO
'BB-SPIDEV1' VER 'N/A' PR '0'
[ 3.662991] bone_capemgr bone_capemgr: slot #4: override
[ 3.663006] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[ 3.663021] bone_capemgr bone_capemgr: slot #4: 'Override Board
Name,00A0,Override Manuf,BB-SPIDEV1'
[ 3.663322] bone_capemgr bone_capemgr: initialized OK.
[ 3.671575] bone_capemgr bone_capemgr: slot #4: dtbo
'BB-SPIDEV1-00A0.dtbo' loaded; overlay id #0
[ 11.231817] LUN: removable file:
/var/cache/doc-beaglebone-getting-started/beaglebone-getting-started-2015-12-04.img

Regards,

I’m confused because I recheck the wired configuration. I also tried on a second beagleboneblack with the same configuration.
So I’m lost. For me it still look like that the problem came from the pin mux.
In fact
`

cat $PINS | grep ‘990|998|994|99c’

pin 100 (44e10990.0) 00000027 pinctrl-single
pin 101 (44e10994.0) 00000027 pinctrl-single
pin 102 (44e10998.0) 00000027 pinctrl-single
pin 103 (44e1099c.0) 00000027 pinctrl-single

`
This mean that the pins are not correctly configure, in fact they should be configure at 0x33 0x33 0x13 and 0x13, isn’t it ?
And since I started configuring caps and pinmux it is the only time It doesn’t correspond with the dts.

dmesg | grep bone

[ 0.000000] Linux version 4.1.18-bone20 (lecostaouec@mppdev) (gcc version 4.9.3 20150413 (prerelease) (Linaro GCC 4.9-2015.05) ) #4 Fri Mar 18 15:16:19 CET 2016
[ 0.000000] Kernel command line: console=ttyO0,115200n8 bone_capemgr.enable_partno=BB-SPIDEV1 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait
[ 3.998684] usb usb1: Manufacturer: Linux 4.1.18-bone20 musb-hcd
[ 4.349285] bone_capemgr bone_capemgr: Baseboard: ‘A335BNLT,00C0,4414BBBK9699’
[ 4.356616] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4
[ 4.422658] bone_capemgr bone_capemgr: slot #0: No cape found
[ 4.482655] bone_capemgr bone_capemgr: slot #1: No cape found
[ 4.542654] bone_capemgr bone_capemgr: slot #2: No cape found
[ 4.602654] bone_capemgr bone_capemgr: slot #3: No cape found
[ 4.608439] bone_capemgr bone_capemgr: enabled_partno PARTNO ‘BB-SPIDEV1’ VER ‘N/A’ PR ‘0’
[ 4.616751] bone_capemgr bone_capemgr: slot #4: override
[ 4.622088] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[ 4.629091] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,BB-SPIDEV1’
[ 4.638497] bone_capemgr bone_capemgr: initialized OK.
[ 4.645406] bone_capemgr bone_capemgr: slot #4: dtbo ‘BB-SPIDEV1-00A0.dtbo’ loaded; overlay id #0

cat /proc/cmdline

console=ttyO0,115200n8 bone_capemgr.enable_partno=BB-SPIDEV1 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait

The other issue could be that we are not using exatly the same version of the kernel

uname -ar

Linux beagle01 4.1.18-bone20 #4 Fri Mar 18 15:16:19 CET 2016 armv7l GNU/Linux

Or I’m I wrong and 4.1.18-ti-r55 is the same as 4.1.18-bone20 ?
Thanks for your time

Hello

I had a similar issue as noted here : https://groups.google.com/forum/#!topic/beagleboard/gOynYr8fgns

I found I could not mux the pins by loading the overlay from the command line BUT it did work when I loaded the overlay via boot/uEnv.txt

I still don’t know why !!!