How to make the customer am335x board both wired and wireless network work simultaneously ?

I built a cutomer board based on beagle bone black but added the wl1835 for wireless. I hope the customer board can use both wired and wireless network simultaneously.

Now I can boot the linux with wired network well. But when I add the wireless overlay in uEnv.txt in RED as below.

#Docs: elinux.org/Beagleboard:U-boot_partitioning_layout_2.0

uname_r=4.4.91-ti-r133
#uuid=
#dtb=

###U-Boot Overlays###
###Documentation: elinux.org/Beagleboard:BeagleBoneBlack_Debian
erlays
###Master Enable
enable_uboot_overlays=1

That's expected as teh "BeagleBone Green Wireless" doesn't have an
ethernet port..

So you'll need to fork:

BB-BBGW-WL1835-00A0.dts

and remove this section:

https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-BBGW-WL1835-00A0.dts#L143-L148

Regards,

Hi Robert Nelson

Thanks for your help.

I cloned the bb.org-overlays source code and tried to build a new dtbo file. I failed.
When I tried to build the single dtbo file I got the error as below.

root@ubuntu:/home/daemondong/Files/bb.org-overlays-master# make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- O=DTOS src/arm/BB-BBGW-WL1835-00A0.dtbo
DTC src/arm/BB-BBGW-WL1835-00A0.dtbo
/bin/sh: 1: -Wp,-MD,src/arm/.BB-BBGW-WL1835-00A0.dtbo.d.pre.tmp: not found
Makefile:144: recipe for target ‘src/arm/BB-BBGW-WL1835-00A0.dtbo’ failed
make: *** [src/arm/BB-BBGW-WL1835-00A0.dtbo] Error 127
root@ubuntu:/home/daemondong/Files/bb.org-overlays-master#

When I tried to build all dtbo files I got the error as below.

root@ubuntu:/home/daemondong/Files/bb.org-overlays-master# make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- O=DTOS all
DTC src/arm/BB-BONE-REPLICAP-0A4A.dtbo
Error: src/arm/BB-BONE-REPLICAP-0A4A.dts:12.2-8 syntax error
FATAL ERROR: Unable to parse input tree
Makefile:144: recipe for target ‘src/arm/BB-BONE-REPLICAP-0A4A.dtbo’ failed
make[1]: *** [src/arm/BB-BONE-REPLICAP-0A4A.dtbo] Error 1
Makefile:90: recipe for target ‘all_arm’ failed
make: *** [all_arm] Error 2
root@ubuntu:/home/daemondong/Files/bb.org-overlays-master#

Would you like to help me to figure it out? Or maybe you can send me the new BB-BBGW-WL1835-00A0.dtbo file to daemondong@163.com.

Thank you very much.

Do it on the Beagle..

Regards,

Hi Robert Nelson

Thanks for your response.

I build the new dtbo file on Beagleboard successfully. But when I use this dtbo file on booting I got the error as below.

Starting kernel …

[ 0.000892] clocksource_probe: no matching clocksources found
[ 2.096964] wkup_m3_ipc 44e11324.wkup_m3_ipc: could not get rproc handle
[ 2.125373] pinctrl-single 44e10800.pinmux: pin 44e10934.0 already requested by 481a6000.serial; cannot claim for 4a100000.ethernet
[ 2.137394] pinctrl-single 44e10800.pinmux: pin-77 (4a100000.ethernet) status -22
[ 2.144945] pinctrl-single 44e10800.pinmux: could not request pin 77 (44e10934.0) from group cpsw_default on device pinctrl-single
[ 2.156845] cpsw 4a100000.ethernet: Error applying setting, reverse things back
[ 2.178149] pinctrl-single 44e10800.pinmux: pin 44e10948.0 already requested by 481a6000.serial; cannot claim for 4a101000.mdio
[ 2.189749] pinctrl-single 44e10800.pinmux: pin-82 (4a101000.mdio) status -22
[ 2.196939] pinctrl-single 44e10800.pinmux: could not request pin 82 (44e10948.0) from group davinci_mdio_default on device pinctrl-single
[ 2.209533] davinci_mdio 4a101000.mdio: Error applying setting, reverse things back
[ 2.349675] davinci_mdio 4a101000.mdio: timed out waiting for user access
[ 2.453669] davinci_mdio 4a101000.mdio: timed out waiting for idle
[ 2.709227] omap_voltage_late_init: Voltage driver support not added
[ 2.717437] PM: Cannot get wkup_m3_ipc handle
rootfs: clean, 76605/217728 files, 442372/869376 blocks
[ 15.337565] libphy: PHY 4a101000.mdio:00 not found
[ 15.342459] net eth0: phy “4a101000.mdio:00” not found on slave 0, err -19

Debian GNU/Linux 9 beaglebone ttyS0

BeagleBoard.org Debian Image 2017-10-10

Support/FAQ: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian

default username:password is [debian:temppwd]

beaglebone login:

I could find the eth0 interface in linux but it couldn’t work. And the wlan0 works well.

debian@beaglebone:~$ ifconfig
SoftAp0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.8.1 netmask 255.255.255.0 broadcast 192.168.8.255
inet6 fe80::8230:dcff:fe73:8e71 prefixlen 64 scopeid 0x20
ether 80:30:dc:73:8e:71 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 30 bytes 6385 (6.2 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

eth0: flags=-28669<UP,BROADCAST,MULTICAST,DYNAMIC> mtu 1500
ether 80:30:dc:73:8e:71 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 175

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1 (Local Loopback)
RX packets 1760 bytes 122400 (119.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1760 bytes 122400 (119.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet 192.168.7.2 netmask 255.255.255.252 broadcast 192.168.7.3
ether 80:30:dc:73:8e:73 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet 192.168.6.2 netmask 255.255.255.252 broadcast 192.168.6.3
ether 80:30:dc:73:8e:76 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC> mtu 1500
inet 10.0.0.13 netmask 255.255.255.0 broadcast 10.0.0.255
inet6 fe80::7a5c:78ff:fe78:785c prefixlen 64 scopeid 0x20
ether 78:5c:78:78:78:5c txqueuelen 1000 (Ethernet)
RX packets 54 bytes 8090 (7.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 82 bytes 18671 (18.2 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

debian@beaglebone:~$

Would you like to help me to figure it out? Thank you very much.

Hi Robert Nelson

I figured it out.

Due to the uart3 conflict with the eth0. The uart3 section should be removed from BB-BBGW-WL1835-00A0.dts.

I removed the line 36 and line 143-148 “fragment@2” and line 178-186 “fragment@4” and made the new dtbo file.

It works well. Thank you very much.