how to pass kernel paraments to omap-beagleboard (kernel)

Hi people, i am trying boot the omap Beagle board by reading Beginners
guide. i am using minicom (linux-serial port) interface, usb keyboard
to usb port of board, and a SD card. i am able to boot, after kernel
boots it asks for login, but i am not able to type anything from
either of keyboards, i want to know how to enter kernel parameters.
guys any idea, wht might be the problem.

thanks

I haven't tried minicom, but gtkterm works fine for me using the
keyboard on the other Linux box. This looks like it may be other than a
program problem as neither keyboard works. The only problem I have is
that the USB keyboard seems to be defined as US rather than gb, with
either the "gb" file being incorrect or being ignored. I can see the
"gb" file in X, but can't find how to change it in console mode.
Regards
Sid.

hi sid, thanks for sharing your experience. i tryed gtkterm,
surprisingly it is working. i dont know whts rong with minicom, it is
not taking anykeys, i was not able to get command promt with minicom.
With gtkterm i am getting beagle command promt.

Thanks

Hi,

I can also suggest you kermit. You can set connection with using these parameters. Dont forget to change ttyUSB0 with your own device

set line /dev/ttyUSB0
set flow-control none
set speed 115200
set parity none
set carrier-watch off
connect

Best Regards,
Bora

My pleasure. I have used gtkterm for many years without problems,
whenever a terminal program was needed to manage Sun/Fujitsu servers
and mainframe gear. An added bonus is that it allows saving everything
to a file, especially as there is no scrollback. It has just worked from
the first version.
Regards
Sid.

guys thanks for sharing your experiences, i am able to boot omap-linux
and play some media files. do u have any idea why android has problem
booting on omap-beagle c2, i am getting kernel-panic no init found.

thanks