How to permanently configure bone_capemgr.9/slots


How can I permanently configure, ‘/sys/devices/bone_capemgr.9/slots’ file on the BBB. I’m able to configure the file for PWM by running the following commands:

echo am33xx_pwm > /sys/devices/bone_capemgr.9/slots
echo bone_pwm_P8_13 > /sys/devices/bone_capemgr.9/slots

However, when I unplug the BBB, the changes get wiped out, and I have to rerun the commands all over again. Thanks.

adding, this to your uEnv.txt should enable them on bootup...



Hi Robert, many thanks for the quick reply. I tried adding that line in both /boot/uEnv.txt as well as /media/BEAGLEBONE/uEnv.txt:

root@beaglebone:~# more /boot/uEnv.txt
optargs=run_hardware_tests quiet

I unplugged/rebooted but the “/sys/devices/bone_capemgr.9/slots” file stayed the same. I guess I could always create my own startup script.

it needs to be one variable:

optargs=run_hardware_tests quiet capemgr.enable_partno=test1,bone_pwm_P8_13


Thanks Robert you #1!