how to reinstall base OS on bbb if purge command has been used to uninstall all packages

hi all,
i have a beaglebone black and ive somehow ended up using ‘apt-get purge *’ which i believe has uninstalled the kernel as well. any ideas on how to get out of this situation?

PS: the intent is to use beaglebone black image of kali linux on it but somehow it couldnt be booted from sd card

You can manually read /var/log/apt/history.log to see what got removed
and when, and then slowly piece together what happened..

But you'll probably just have to start from a fresh image.

Regards,

i could only access the board using remote ssh login and as of now, the board doesnt have an ip address. i tried installing a new image using the microsd card, but it isnt working either.

Which image did you write to the microSD, and what it "doing" or "not doing"?

Regards,

i wrote debian 7.5 (eMMC flasher) to micro SD card. when i try to boot with or without using the card, all 4 leds of the board remain “ON” continuously.

Sorry, i'm not debugging 7.5 and that old 3.8.x based kernel from 2014.

Grab the latest SD IoT image:

https://beagleboard.org/latest-images

Regards,

well, i tried using debian10.3-iot but it still isnt working.

i powered off the board, then i put the microsd card in the slot and switched the board on keeping the S2 button pressed. there was no activity on the LED lights. and when i dont press the S2 button, all 4 LED lights stay ON continuously.

What application did you use to write the image to the microSD?

Ecther.io?

Or that Win32DiskImager (which has been known to be broken for the
last few months..)

Regards,

i used dd. i only have linux/mac.

Etcher works with Linux and Mac:
https://www.balena.io/etcher/

It’s fine for uSD cards less than 64GB, otherwise you need to format the card as ExFAT first.

Jon

thank you so much guys. the issue got resolved. i guess the problem was with the flash software. i was using command line but etcher worked just fine…
thanks again

Regards
Amrinder

And if it truly is a Mac, recommend using
https://www.sdcard.org/downloads/formatter/ for formatting the card first.