How to update kernel in Ubuntu

Hi all,
I have a Beagleboard xM (rev.C) and I installed Ubuntu Oneiric thanks to RobertCNelson netinstall’s script. I received the notification for new updates and I did them, but kernel update went wrong: USB don’t work anymore, screen resolution is very low and there’s no serial console
My question is, how can I update kernel preserving all the things specially configured for my board?

PS: after this problem I tried the Robert’s script for update the kernel, something works again, but configuration isn’t perfect as it was before.



Humm, ignore my github reply... This actually sounds like they
overwrote the bootloader with the update.. Can you pastebin your
serial boot log for me.. And list the (ls -lh) contents of the fat
boot partition..


I formatted the memory card. Now I want to test your script on a fresh
install to exclude it is the reason of the problem.

Kernel update through the script went perfectly, so I conclude you
never try to update kernel with Ubuntu Update Manager.
I hope in the next update Ubuntu won't ask for linux header update :slight_smile:
When I can I'll try to perforn a system update. I want to ensure
there's no conflict.

Thanks for your help, Robert.

Sorry, my bad, I did a mistake on the last message:
"so I conclude you CAN'T update kernel with Ubuntu Update Manager."


Okay, this should stop it from ever happening again.. :wink:

but i need to retest maverick/natty to make sure that doesn't break them too...

a simple: "sudo apt-get remove -y linux-image-omap*
linux-headers-omap* u-boot-linaro* x-loader-omap* flash-kernel" should
remove anything from ubuntu/linaro that would break your system in an


Unless you'd like to use Ubuntu/Linaro's kernel/bootloader you can...
:wink: But depending on which board you have and any expansion adapters
you have plugged into the board, it'll probally fail (like usb)..

Once your using on of my kernel's, you can update to pretty much any


Why don't you make a PPA repo for Ubuntu?
Can you automate the creation of uImage and uInitrd into the deb? (I
don't know how debs works)

Why don't you make a PPA repo for Ubuntu?

It was faster, easier to put this in a script:

export DIST=oneiric
rm -f LATEST-omap || true
wget $(cat ./LATEST-omap | grep STABLE | awk '{print $3}')

Can you automate the creation of uImage and uInitrd into the deb? (I
don't know how debs works)

No, after installing/unpacking the deb into the system, the uImage and
uInitrd can then be created..

In the case of omap, uImage isn't a big deal, as it's (so far omap3/4)
only 0x80008000.. (but if you look at other soc's such as freescale's,
there mx51 != mx53 for that address..)

For uInitrd, this has to be generated by "update-initramfs" and has to
be running on the target system... (now these aren't necessary
required, but for ubuntu it allows us to run a time fix script on



I apologize if I'm posting maybe out of context but i think it might
be related.

I installed Oneiric through net install method.

Used instructions from page below to build SGX.

So, downloaded kernel, (git, toolchain 2011.03)

QUESTION IS: Do i need to install this downloaded kernel to make SGX
work or I just need to install libraries?
If i need to install kernel, what's the procedure for that?

Thank you

No.. As long as your still running my kernel.. (Well as long as you
used my netinstall after this commit today...
as ubuntu/linaro in oneiric tried to take over from my kernel image..
) :wink:

uname -r would let me know.. :wink:

The SGX kernel modules are included in my kernel builds..

So from:

From where your at, you would just start in the "SDK unPackage Script" section..

Side, note those directions worked fine for Lucid/Maverick/Natty &
Squeeze.. I haven't had time to test Oneiric fully so they may or may
not work...


Thank you on fast reply :slight_smile:

I wasn't able to test SGX modules from your netinstall in As SGX test
applications are not included. So, i tried to use latest test
applciations but they complained about missing libraries even if i
install all necessary sgx packages.

Then lets rephrase my goal :slight_smile:
I need working Qt libraries with SGX acceleration. I noticed that
libraries which are part of ubuntu use mesa drivers. So tried to
compile on my own.

So, which dsitribution should I choose? Natty? Then recompile Qt?
latest toolchain?

Thank you in advance

OK, i tried your latest script. But it failed to create MMC card:

sudo ./ --mmc /dev/sdb --uboot beagle --distro oneiric


OK, i tried your latest script. But it failed to create MMC card:

sudo ./ --mmc /dev/sdb --uboot beagle --distro oneiric

Formating Boot Partition
mkfs.vfat 3.0.9 (31 Jan 2010)
`/tmp/tmp.oiudvxQ7pI/dl/MLO-beagleboard-1.5.1-r3' -> `/tmp/
`/tmp/tmp.oiudvxQ7pI/dl/u-boot-beagleboard-2011.09-r4.bin' -> `/tmp/
ls: cannot access /home/user/Documents/work/method_2/netinstall/
vmlinuz-**: No such file or directory
Using mkimage to create uImage
Usage: mkimage -l image
-l ==> list image header information
mkimage [-x] -A arch -O os -T type -C comp -a addr -e ep -n
name -d data_file[:data_file...] image
-A ==> set architecture to 'arch'
-O ==> set operating system to 'os'
-T ==> set image type to 'type'
-C ==> set compression type 'comp'
-a ==> set load address to 'addr' (hex)
-e ==> set entry point to 'ep' (hex)
-n ==> set image name to 'name'
-d ==> use image data from 'datafile'
-x ==> set XIP (execute in place)
mkimage [-D dtc_options] -f fit-image.its fit-image

Please report these bugs at:

In the report, I need to know your distro/version.. aka "Fedora 12
32bit" and attach the FULL terminal log of the script..


New netinstall version works correctly.
Still having problems to run demos but moved discussion in new thread
as it doesn't belong here. Link to thread: