Howto configure Angstrom for hard float

Hi all,

How do I globally configure Angstrom to use hardfp? I found the following discussion in a Google group:

https://groups.google.com/forum/#!msg/beagleboard/BndeIRB_pY8/Cl5kdqAvIUoJ

Which appears to suggest that it simply requires adding the ARM_FP_MODE = “hardfp” definition to the local.conf file. However, I tried that and still see packages referencing soft-stubs.h.

I am trying to build the TI DSP software and am getting a failure on the linuxutils package:

`

arm-angstrom-linux-gnueabi-gcc -I. -Wall -c -g -D__DEBUG -o debug/cmem.o470MV cmem.c
In file included from /projects/angstrom/build/tmp-angstrom_v2014_12-glibc/sysroots/beagleboard/usr/include/features.h:389:0,
from /projects/angstrom/build/tmp-angstrom_v2014_12-glibc/sysroots/beagleboard/usr/include/stdio.h:27,
from cmem.c:38:
/projects/angstrom/build/tmp-angstrom_v2014_12-glibc/sysroots/beagleboard/usr/include/gnu/stubs.h:7:29: fatal error: gnu/stubs-soft.h: No such file or directory

include <gnu/stubs-soft.h>


ERROR: Task 263 (/projects/angstrom/sources/meta-ti/recipes-ti/linuxutils/ti-linuxutils_2.26.01.02.bb, do_compile) failed with exit code ‘1’
`

The cross tools are built for hardfp but it appears linuxutils is still trying to reference softfp.

Is the ARM_FP_MODE the proper flag for global Angstrom FP configuration? Does something need to be done after local.conf is modified for it to take affect?

Thanks