I did not login xorg. help me.

I tried to install ubuntu on my BB following the instruction this web
page
http://elinux.org/BeagleBoardHandheldsMojo

sudo aptitude install xorg gdm xfce4 (375Mb)

Modify /etc/X11/xorg.conf

Section "Device"
  Identifier "Configured Video Device"
  Option "UseFBDev" "true"
  Driver "fbdev"
EndSection

I did that section.
and I did type startx instruction on my shell.
first time my BB works very well.
but I did reboot my BB it did not working.
before the login window my keyboard and mouse are good.
but next(login window) my keyboard and mouse did not working.
I think my keyboard is something wrong. So I tried another key board .
but It did not working, too.

In short, my BB always stop in login window. but keyboard and mouse
did not working.

How can I solve this problem?

help me, plz.

thanks.

Strange, sounds like the usb subsystem locked up, is there any errors
showing up on the serial port. (with the default setup most errors
will dump there).

Are you running a powered usb hub? I've noticed that 'some cheap'
ones do tend to lock up and require a power reset on the next BB
boot...

Regards,

I did Change USB Hub but It is Same.
I think USB Hub is not a problem.

My BB enter the xubuntu login page. only 3~4 second my keyboard and
mouse work and 3~4 second later they stop.

serial port out put:

Starting
kernel ...

Uncompressing
Linux.............................................................
Linux version 2.6.27-oer4 (root@debian-armel) (gcc version 4.2.3
(Handhelds 4.28
CPU: ARMv7 Processor [411fc082] revision 2 (ARMv7),
cr=00c5387f
Machine: OMAP3 Beagle
Board
Memory policy: ECC disabled, Data cache
writeback
OMAP3430
ES2.1
SRAM: Mapped pa 0x40200000 to va 0xd7000000 size:
0x100000
CPU0: L1 I VIPT cache. Caches unified at level 2, coherent at level
3
CPU0: Level 1 cache is separate instruction and
data
CPU0: I cache: 16384 bytes, associativity 4, 64 byte lines, 64
sets,
      supports
RA
CPU0: D cache: 16384 bytes, associativity 4, 64 byte lines, 64
sets,
      supports RA WB
WT
CPU0: Level 2 cache is
unified
CPU0: unified cache: 262144 bytes, associativity 8, 64 byte lines, 512
sets,
      supports WA RA WB
WT
Built 1 zonelists in Zone order, mobility grouping on. Total pages:
32512
Kernel command line: console=ttyS2,115200n8 console=tty0 root=/dev/
mmcblk0p5 ro0
Clocking rate (Crystal/DPLL/ARM core): 26.0/332/600
MHz
GPMC revision
5.0
IRQ: Found an INTC at 0xd8200000 (revision 4.0) with 96
interrupts
Total of 96 interrupts on 1 active
controller
OMAP34xx GPIO hardware version
2.5
PID hash table entries: 512 (order: 9, 2048
bytes)
OMAP clockevent source: GPTIMER12 at 32768
Hz
Console: colour dummy device
80x30
console [tty0]
enabled
Dentry cache hash table entries: 16384 (order: 4, 65536
bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768
bytes)
Memory: 128MB = 128MB
total
Memory: 125212KB available (4012K code, 360K data, 180K
init)
Calibrating delay loop... 580.84 BogoMIPS
(lpj=2269184)
Mount-cache hash table entries:
512
CPU: Testing write buffer coherency:
ok
net_namespace: 488
bytes
NET: Registered protocol family
16
Found NAND on
CS0
Registering NAND on
CS0
OMAP DMA hardware revision
4.0
USB: No board-specific platform config
found
i2c_omap i2c_omap.1: bus 1 rev3.12 at 2600
kHz
twl4030: PIH (irq 7) chaining IRQs
368..375
twl4030: power (irq 373) chaining IRQs
376..383
twl4030: gpio (irq 368) chaining IRQs
384..401
i2c_omap i2c_omap.3: bus 3 rev3.12 at 400
kHz
twl4030_usb twl4030_usb: Initialized TWL4030 USB
module
SCSI subsystem
initialized
usbcore: registered new interface driver
usbfs
usbcore: registered new interface driver
hub
usbcore: registered new device driver
usb
musb_hdrc: version 6.0, musb-dma, host,
debug=0
musb_hdrc: USB Host mode controller at d80ab000 using DMA, IRQ
92
musb_hdrc musb_hdrc: MUSB HDRC host
driver
musb_hdrc musb_hdrc: new USB bus registered, assigned bus number
1
usb usb1: configuration #1 chosen from 1
choice
hub 1-0:1.0: USB hub
found
hub 1-0:1.0: 1 port
detected
Bluetooth: Core ver
2.13
NET: Registered protocol family
31
Bluetooth: HCI device and connection manager
initialized
Bluetooth: HCI socket layer
initialized
NET: Registered protocol family
2
IP route cache hash table entries: 1024 (order: 0, 4096
bytes)
TCP established hash table entries: 4096 (order: 3, 32768
bytes)
TCP bind hash table entries: 4096 (order: 2, 16384
bytes)
TCP: Hash tables configured (established 4096 bind
4096)
TCP reno
registered
NET: Registered protocol family
1
VFS: Disk quotas
dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096
bytes)
JFFS2 version 2.2. (NAND) (SUMMARY) �© 2001-2006 Red Hat,
Inc.
msgmni has been set to
244
io scheduler noop
registered
io scheduler anticipatory
registered
io scheduler deadline
registered
io scheduler cfq registered
(default)
omapfb: using mode
1024x768@60
omapfb: configured for panel
omap3beagle
omapfb: DISPC version 3.0
initialized
Console: switching to colour frame buffer device
128x48
omapfb: Framebuffer initialized. Total vram 1572864 planes
1
omapfb: Pixclock 54000 kHz hfreq 45.6081 kHz vfreq 57.7
Hz
Serial: 8250/16550 driver4 ports, IRQ sharing
enabled
serial8250.0: ttyS0 at MMIO 0x4806a000 (irq = 72) is a
ST16654
serial8250.0: ttyS1 at MMIO 0x4806c000 (irq = 73) is a
ST16654
serial8250.0: ttyS2 at MMIO 0x49020000 (irq = 74) is a
ST16654
console [ttyS2]
enabled
brd: module
loaded
loop: module
loaded
usb 1-1: new high speed USB device using musb_hdrc and address
2
usb 1-1: configuration #1 chosen from 1
choice
hub 1-1:1.0: USB hub
found
hub 1-1:1.0: 4 ports
detected
usb 1-1.2: new low speed USB device using musb_hdrc and address
3
usb 1-1.2: configuration #1 chosen from 1
choice
usbcore: registered new interface driver
asix
usbcore: registered new interface driver
cdc_ether
i2c /dev entries
driver
input: triton2-pwrbutton as /class/input/
input0
triton2 power button driver
initialized
Driver 'sd' needs updating - please use bus_type
methods
omap2-nand driver
initializing
NAND device: Manufacturer ID: 0x2c, Chip ID: 0xba (Micron NAND 256MiB
1,8V 16-b)
cmdlinepart partition parsing not
available
Creating 5 MTD partitions on "omap2-
nand":
0x00000000-0x00080000 : "X-
Loader"
0x00080000-0x00260000 : "U-
Boot"
0x00260000-0x00280000 : "U-Boot
Env"
0x00280000-0x00680000 :
"Kernel"
0x00680000-0x10000000 : "File
System"
usbmon: debugfs is not
available
Initializing USB Mass Storage
driver...
usbcore: registered new interface driver usb-
storage
USB Mass Storage support
registered.
mice: PS/2 mouse device common for all
mice
twl4030_rtc twl4030_rtc: rtc core: registered twl4030_rtc as
rtc0
twl4030_rtc twl4030_rtc: Power up reset
detected.
twl4030_rtc twl4030_rtc: Enabling TWL4030-
RTC.
OMAP Watchdog Timer Rev 0x31: initial timeout 60
sec
Bluetooth: HCI USB driver ver
2.10
usbcore: registered new interface driver
hci_usb
Bluetooth: Broadcom Blutonium firmware driver ver
1.2
usbcore: registered new interface driver
bcm203x
Bluetooth: Digianswer Bluetooth USB driver ver
0.10
usbcore: registered new interface driver
bpa10x
Bluetooth: Generic Bluetooth SDIO driver ver
0.1
Registered led device:
beagleboard::usr0
Registered led device:
beagleboard::usr1
Registered led device:
beagleboard::pmu_stat
input: 2.4G USB RF KeyBoard as /class/input/
input1
input: USB HID v1.10 Keyboard [2.4G USB RF KeyBoard] on usb-
musb_hdrc-1.2
input: 2.4G USB RF KeyBoard as /class/input/
input2
input: USB HID v1.10 Mouse [2.4G USB RF KeyBoard] on usb-
musb_hdrc-1.2
usbcore: registered new interface driver
usbhid
usbhid: v2.6:USB HID core
driver
Advanced Linux Sound Architecture Driver Version
1.0.17.
usbcore: registered new interface driver snd-usb-
audio
ASoC version
0.13.2
OMAP3 Beagle SoC
init
TWL4030 Audio Codec
init
asoc: twl4030 <-> omap-mcbsp-dai mapping
ok
ALSA device
list:
  #0: omap3beagle
(twl4030)
oprofile: using arm/
armv7
TCP cubic
registered
NET: Registered protocol family
17
NET: Registered protocol family
15
Bluetooth: L2CAP ver
2.11
Bluetooth: L2CAP socket layer
initialized
Bluetooth: SCO (Voice Link) ver
0.6
Bluetooth: SCO socket layer
initialized
Bluetooth: RFCOMM socket layer
initialized
Bluetooth: RFCOMM TTY layer
initialized
Bluetooth: RFCOMM ver
1.10
Bluetooth: BNEP (Ethernet Emulation) ver
1.3
Bluetooth: BNEP filters: protocol
multicast
Bluetooth: HIDP (Human Interface Emulation) ver
1.2
RPC: Registered udp transport
module.
RPC: Registered tcp transport
module.
ieee80211: 802.11 data/management/control stack,
git-1.1.13
ThumbEE CPU extension
supported.
Power Management for TI
OMAP3.
SmartReflex driver
initialized
Disabling unused clock
"sr2_fck"
Disabling unused clock
"sr1_fck"
Disabling unused clock
"mcbsp_fck"
Disabling unused clock
"mcbsp_fck"
Disabling unused clock
"mcbsp_fck"
Disabling unused clock
"mcbsp_ick"
Disabling unused clock
"mcbsp_ick"
Disabling unused clock
"mcbsp_ick"
Disabling unused clock
"gpt2_ick"
Disabling unused clock
"gpt3_ick"
Disabling unused clock
"gpt4_ick"
Disabling unused clock
"gpt5_ick"
Disabling unused clock
"gpt6_ick"
Disabling unused clock
"gpt7_ick"
Disabling unused clock
"gpt8_ick"
Disabling unused clock
"gpt9_ick"
Disabling unused clock
"wdt3_ick"
Disabling unused clock
"wdt3_fck"
Disabling unused clock
"gpio2_dbck"
Disabling unused clock
"gpio3_dbck"
Disabling unused clock
"gpio4_dbck"
Disabling unused clock
"gpio5_dbck"
Disabling unused clock
"gpio6_dbck"
Disabling unused clock
"gpt9_fck"
Disabling unused clock
"gpt8_fck"
Disabling unused clock
"gpt7_fck"
Disabling unused clock
"gpt6_fck"
Disabling unused clock
"gpt5_fck"
Disabling unused clock
"gpt4_fck"
Disabling unused clock
"gpt3_fck"
Disabling unused clock
"gpt2_fck"
Disabling unused clock
"gpt1_ick"
Disabling unused clock
"wdt1_ick"
Disabling unused clock
"wdt2_ick"
Disabling unused clock
"wdt2_fck"
Disabling unused clock
"gpio1_dbck"
Disabling unused clock
"gpt1_fck"
Disabling unused clock
"cam_ick"
Disabling unused clock
"cam_mclk"
Disabling unused clock
"des1_ick"
Disabling unused clock
"sha11_ick"
Disabling unused clock
"rng_ick"
Disabling unused clock
"aes1_ick"
Disabling unused clock
"ssi_ick"
Disabling unused clock
"mailboxes_ick"
Disabling unused clock
"mcbsp_ick"
Disabling unused clock
"mcbsp_ick"
Disabling unused clock
"gpt10_ick"
Disabling unused clock
"gpt11_ick"
Disabling unused clock
"i2c_ick"
Disabling unused clock
"mcspi_ick"
Disabling unused clock
"mcspi_ick"
Disabling unused clock
"mcspi_ick"
Disabling unused clock
"mcspi_ick"
Disabling unused clock
"hdq_ick"
Disabling unused clock
"mspro_ick"
Disabling unused clock
"mmchs_ick"
Disabling unused clock
"des2_ick"
Disabling unused clock
"sha12_ick"
Disabling unused clock
"aes2_ick"
Disabling unused clock
"icr_ick"
Disabling unused clock
"pka_ick"
Disabling unused clock
"ssi_ssr_fck"
Disabling unused clock
"hdq_fck"
Disabling unused clock
"mcspi_fck"
Disabling unused clock
"mcspi_fck"
Disabling unused clock
"mcspi_fck"
Disabling unused clock
"mcspi_fck"
Disabling unused clock
"mcbsp_fck"
Disabling unused clock
"mcbsp_fck"
Disabling unused clock
"i2c_fck"
Disabling unused clock
"mspro_fck"
Disabling unused clock
"mmchs_fck"
Disabling unused clock
"gpt11_fck"
Disabling unused clock
"gpt10_fck"
Disabling unused clock
"iva2_ck"
Disabling unused clock
"dpll5_ck"
Disabling unused clock
"dpll4_m6x2_ck"
Disabling unused clock
"dpll4_m5x2_ck"
Disabling unused clock
"dpll3_m3x2_ck"
Disabling unused clock
"sys_clkout1"
VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev
1
twl4030_rtc twl4030_rtc: setting system clock to 2000-01-01 00:00:01
UTC (94668)
Waiting 2sec before mounting root
device...
mmc0: host does not support reading read-only switch. assuming write-
enable.
mmc0: new high speed SDHC card at address
0001
mmcblk0: mmc0:0001 SDC
3935232KiB
mmcblk0: p1 p2 < p5 p6

EXT3-fs: INFO: recovery required on readonly
filesystem.
EXT3-fs: write access will be enabled during
recovery.
kjournald starting. Commit interval 5
seconds
EXT3-fs: recovery
complete.
EXT3-fs: mounted filesystem with ordered data
mode.
VFS: Mounted root (ext3 filesystem)
readonly.
Freeing init memory:
180K
end_request: I/O error, dev mtdblock0, sector
0
Buffer I/O error on device mtdblock0, logical block
0
end_request: I/O error, dev mtdblock0, sector
8
Buffer I/O error on device mtdblock0, logical block
1
end_request: I/O error, dev mtdblock0, sector
16
Buffer I/O error on device mtdblock0, logical block
2
end_request: I/O error, dev mtdblock0, sector
24
Buffer I/O error on device mtdblock0, logical block
3
end_request: I/O error, dev mtdblock0, sector
0
Buffer I/O error on device mtdblock0, logical block
0
fuse init (API version 7.9)