I2C-2 times out on the Zippy Board

I am a newbie here, so pardon me if I am missing any details.

I have been trying to get I2C-2 working on Beagle Board with the Zippy
Beagle Buddy Board connected.

I2C-2 works fine for me when Beagle Board is used by itself and pull
up resistors (10K) are connected. I was able to verify this by using

The problem is that when I connect the Zippy Board, I2C-2 starts
timing out. I have tried using the uImage, u-boot.bin and MLO supplied
by TinCan. I also tried applying the patch to my kernel and using
that. Both ways, I get time out errors.

I am seeing two problems (please see the complete boot log below for
details). One is that my RTC DS1307 probe fails and the other is that
my I2C-2 is timing out.

The two relevant lines from the boot log that I think is the problem
is -

     [ 21.677978] i2c_omap i2c_omap.2: controller timed
     [ 21.683197] rtc-ds1307: probe of 2-0068 failed with error

I would appreciate some help on this.

I think the i2c-2 path on zippy board is problematic. You can get a
scope to take a look at the signals on SCL and SDA, then you will know
My suggestion is dump it right away and make your own board with a
different level translator.