I2C device detection (Interfacing with kx022 magnetometer)

Good day,

i’m having an issue with my beaglebone black. When I run the “i2cdetect -y -r 2”, it shows the address map without detecting the device and if I run “i2cget -y 2 0x1e 0x0f b”
I get an error: “Error: Read Failed” as shown in the following picture (https://photos.app.goo.gl/DYA4Pa7ySyA4CGMk1). Note that I’m interfacing the beaglebone black with the Kx022 magnetometer. This is what the Kernel log shows (https://photos.app.goo.gl/owkR1CrGRTLrcD1K3).
Please note that I’m fairly new with this.

Thanks In advance,

Well, until you can see it with i2cdetect, you don’t have a chance of running software successfully.

Are there any other I2C devices on the bus that you can see, so that you know the bus is working correctly?
Where (which pins) is the bus connected?
What value of pull-up resistors are you using?
Do you have another i2c device you can hook to the bus to test it?

— Graham

Good day Graham,
Got it working thanks for the intention to help.