I2C no longer functions on P9-19 and P9-20

I built a system around a BeagleBone Black Rev some time ago with the I2C bus connected to Pins P9-19 (SCL) and P9-20 (SDA). I have three or four prototypes configured that way, they’ve all worked fine and I have not touched the I2C code for quite some time.

I recently bought another BeagleBone Black Rev C from Mouser and it was manufactured by GHI. I plugged it into an existing system and installed the SD memory from a functioning system into it and could not see any activity on the I2C bus, nothing. I swapped it with the BBB originally in the system and that BBB worked fine. I swapped again and the new one still would not communicate over the I2C bus. I tried the new one on two other systems with the same results. I contacted GHI and the sent a replacement. It doesn’t work either. Everything on these two new BBB Rev C works as expected except the I2C bus on P9-19 and P9-20.

Since the memory is POP right on top the processor I can’t tell it the processor revision is the same between the older BBB and the newest BBB. I suspect that TI may have rev’ed the silicon and this bus is no longer available on these pins. But if this is the case then not all Rev C BBB’s are created equal, at least according to the documentation. And I can’t find anything to confirm this.

Any one have any idea what is going on here?


Wow, the memory isn't POP.. Package On Package... The memory is a
seperate chip on the board..

Your I2C issues is probally the eMMC bootloader getting in the way of
your "sd image"..

Just run:

sudo dd if=/dev/zero of=/dev/mmcblk1 bs=1M count=10

and enjoy your image.