I2C2 and DCAN_0 conflict

I’m trying to get DCAN0 to work on the Beaglebone Black (element14 industrial version). Not surprising configure-pin doesn’t work out of the box since I2C2 is used for Capes

root@beaglebone:~# config-pin p9.19 can

Pin is not modifyable: P9_19 i2c2_scl

I’ve no use for the capes (only our custom board). Web searches indicate that it should be possible to disable i2c2 and allow DCAN0 to be enabled. I’ve not figure out what needs to be done though.

Installed version:

root@beaglebone:~# uname -a

Linux beaglebone 4.1.15-ti-rt-r43 #1 SMP PREEMPT RT Thu Jan 21 20:13:58 UTC 2016 armv7l GNU/Linux

My latest attempt was to follow these instructions to little avail https://www.bacpeters.com/2020/01/25/configuring-the-beaglebone-black-gpio-pins-permanently/

I’ve also tried disabling the I2C2 following the instructions here http://www.embedded-things.com/bbb/enable-canbus-on-the-beaglebone-black/

And by simply commenting out the I2C2 section in am335x-boneblack or marking it as disabled rather than okay.

All attempts appear to be ignored though as config-pin always returns the same error message.