I2C2 on BeagleBoard Angstrom gives Read/Write Error

We have couple of BeagleBoards, C3 version, and we are using latest
Angstrom code base. One of the BeagleBoard always gives I2C Read/Write
Error, where as the other one works correctly.
On the beagleboard, we have connected to the i2c-2 pins on the
expansion connector (pin 23 for SDA, pin 24 for SCL, pin 27 for
We were expecting clock signal on SCL when no Slave Device connected.
Still, tried the data flow by connecting I2C Slave peripheral, which
works at 1.8V. With this setup, SCL and SDA lines are always pulled
High. No clock toggling is observed on SCL line.
When the above setup didn't work, we have even tried additional pull-
ups on SDA & SCL lines of expansion headers(4.7 K resistors as
external pullup), without any success
Zoheb from IDA Systems has suggested us to post the issue to the core
Could you please suggest how to proceed further with this I2C2 noon-
working BeagleBoard?


Did you perhaps solve your problem? I ask, because I have similar problem and don’t know how to solve it.

понедељак, 11. јануар 2010. 10.01.06 UTC+1, Ramanath је написао/ла: