image-builder fails to produce image

Hello, folks,

I am trying to build my own custom image to boot my beagleboard-xm.

When I pulled latest image-builder from github and tried to run the stript with the command ‘./ -c rcn-ee_console_ubuntu_xenial_armhf’, it ended up with the following error message;


update-initramfs: Generating /boot/initrd.img-4.1.18-ti-r53

Log: (chroot): system_tweaks

Log: (chroot): set_locale

Log: (chroot) Ubuntu: setting up locales: [en_US.UTF-8]

Generating locales (this might take a while)…

en_US.UTF-8… done

Generation complete.

Log: (chroot): manual_deborphan

Log: (chroot): add_user





Log: (chroot) adding admin group to /etc/sudoers

ubuntu:x:1000:1000:Demo User:/home/ubuntu:/bin/bash

passwd: password expiry information changed.

Log: (chroot): startup_script

Log: (chroot): ubuntu_startup_script

qemu: Unsupported syscall: 384

Created symlink /etc/systemd/system/, pointing to /lib/systemd/system/generic-board-startup.service.

qemu: Unsupported syscall: 384

Created symlink /etc/systemd/system/, pointing to /lib/systemd/system/capemgr.service.

Log: (chroot) Warning, qemu can fail here… (run on real armv7l hardware for production images)

Log: (chroot): [git clone /opt/scripts/ --depth 1]

Cloning into ‘/opt/scripts’…

POST git-upload-pack (155 bytes)

POST git-upload-pack (164 bytes)

remote: Counting objects: 119, done.

remote: Compressing objects: 100% (97/97), done.

remote: Total 119 (delta 26), reused 60 (delta 10), pack-reused 0

Receiving objects: 100% (119/119), 298.43 KiB | 204.00 KiB/s, done.

qemu: uncaught target signal 11 (Segmentation fault) - core dumped

error: --shallow-file died of signal 11

fatal: index-pack failed

Log: umount: [/workspace/devel/beagleboard/image-builder/ignore/tmp.oyODR1MpJo/dev/pts]

Log: umount: [/workspace/devel/beagleboard/image-builder/ignore/tmp.oyODR1MpJo/proc]

Log: umount: [/workspace/devel/beagleboard/image-builder/ignore/tmp.oyODR1MpJo/sys]

Log: umount: [/workspace/devel/beagleboard/image-builder/ignore/tmp.oyODR1MpJo/run]


I used to use earlier version of this script three to four years back without problem, but it does not give me the expected image this time. I tried with all the pre-configured ubuntu configurations (five in total) in the configs/ directory but none of them were successful.

Is there anybody has a clue?

For your information, I am running ubuntu-14.04 LST with Intel i7 core and 16G SDRAM, and the following is the output of ‘uname -a’ command;

Linux freeman-ubuntu14 3.13.0-67-generic #110-Ubuntu SMP Fri Oct 23 13:24:41 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I also attached the full log of the script running.



image-builder_log.txt (102 KB)

qemu failure on x86, this is normal-ish 50% of the time..

Try running it a second time..

Otherwise, invest in a real arm builder.