install python module but it's not found; what am i doing wrong?

I thought I had broken my installation of python-twisted, so I uninstalled and reinstalled, but now it doesn't show up:

root@beagleboard:~# opkg remove python-twisted
Removing package python-twisted from root...

root@beagleboard:~# opkg install python-twisted
Installing python-twisted (8.2.0-r2.6) to root...
Downloading http://feeds.angstrom-distribution.org/feeds/unstable/ipk/glibc/armv7a/python/python-twisted_8.2.0-r2.6_armv7a.ipk.
Configuring python-twisted.

root@beagleboard:~# find / -name twisted

root@beagleboard:~# ls /usr/lib/python2.6/site
/usr/lib/python2.6/site-packages/ /usr/lib/python2.6/sitecustomize.py
/usr/lib/python2.6/site.py /usr/lib/python2.6/sitecustomize.pyo
/usr/lib/python2.6/site.pyo
root@beagleboard:~# ls /usr/lib/python2.6/site-packages/
CORBA.py
CORBA.pyo
ORBit.so
PortableServer.py
PortableServer.pyo
gtk-2.0
setuptools.pth
site.py
site.pyo
zope.interface-3.5.1-py2.6-linux-x86_64.egg

In contrast, on my Ubuntu system, I see:

michael@t61p:~/Ubuntu One/projects/beagleboard/ruby$ find /usr -name twisted
/usr/lib/python2.7/dist-packages/twisted
and many others

What silly mistake am I making?

Michael,

Perhaps the version of python-twisted you reinstalled is intended for
use a different python version (e.g. 2.7), and was installed in that
folder? Did you check the output of

opkg files python-twisted

If the opkg version won't install properly, another option would be to
install it using easy_install. (If you don't have easy_install, you
can install it using opkg install python_setuptools). However,
installing twisted that way will likely require native compilation of
code, which opens a whole new can of worms :-).

Dan.