Installing kernel headers for ubuntu

Hi Robert,
I tried that first, but it failed with

LZMA arch/arm/boot/compressed/piggy.lzma

lzma: (stdin): Cannot allocate memory

So I thought that compiling on the device wasn’t possible and that’s when I tried it in a vm.

Thanks,

Greg

Add a swap file...

besides, the file is already in the source:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=blob;f=include/linux/uvcvideo.h;h=f46a53f060d7dd976b6767123d92a6f039a5ce0d;hb=refs/heads/linux-3.2.y

Try actually building against the file..

Regards,

Hi Robert,
When I copy in uvcvideo.h into /usr/include/linux configure complains and excludes the plugin from building

configure: *** checking feature: UVC H264 ***
configure: *** for plug-ins: uvch264 ***
checking linux/uvcvideo.h usability… no
checking linux/uvcvideo.h presence… yes
configure: WARNING: linux/uvcvideo.h: present but cannot be compiled
configure: WARNING: linux/uvcvideo.h: check for missing prerequisite headers?
configure: WARNING: linux/uvcvideo.h: see the Autoconf documentation
configure: WARNING: linux/uvcvideo.h: section “Present But Cannot Be Compiled”
configure: WARNING: linux/uvcvideo.h: proceeding with the compiler’s result
configure: WARNING: ## ------------------------------------------------------------------------ ##
configure: WARNING: ## Report this to http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer ##
configure: WARNING: ## ------------------------------------------------------------------------ ##
checking for linux/uvcvideo.h… no
checking for GST_VIDEO… yes
checking for G_UDEV… yes
checking for LIBUSB… yes
configure: *** These plugins will not be built: uvch264

I created the swap file and was able to build the zImage on the device. Where are the generated headers located after doing this step?

Thanks,
Greg

https://help.ubuntu.com/community/SwapFaq

Regards,