Installing Python Libraries to access GIOP on BeagleBone through Ubuntu 14.04

Background
I am working on Virtual Machine, using 32bit Ubuntu and have successfully connected to the remote server using the beaglebone’s IP address after installing the required bone drivers for the beaglebone. I want to access GIOP of BeagleBone Black and be able to run a DC motor on it. I have tried following this tutorial by adafruit:

https://learn.adafruit.com/setting-up-io-python-library-on-beaglebone-black/installation-on-ubuntu

but I seem to get errors in the early stages.

Errors
My first error is with the very first command using "

  1. sudo ntpdate pool.ntp.org to set the right date and time. But I get the following errors:
  2. root@beaglebone:~# sudo ntpdate pool.ntp.org Error resolving pool.ntp.org: Name or service not known (-2) 23 Apr 21:18:42 ntpdate[2034]: Can’t find host pool.ntp.org: Name or service not known (-2) 23 Apr 21:18:43 ntpdate[2034]: no servers can be used, exiting root@beaglebone:~# sudo apt-get update Err http://debian.beagleboard.org wheezy-bbb Release.gpg Could not resolve ‘debian.beagleboard.org’ Err http://security.debian.org wheezy/updates Release.gpg Could not resolve ‘security.debian.org’ Err http://ftp.us.debian.org wheezy Release.gpg Could not resolve ‘ftp.us.debian.org’ Err http://ftp.us.debian.org wheezy-updates Release.gpg Could not resolve ‘ftp.us.debian.org’ Reading package lists… Done W: Failed to fetch http://ftp.us.debian.org/debian/dists/wheezy/Release.gpg Could not resolve ‘ftp.us.debian.org’ W: Failed to fetch http://ftp.us.debian.org/debian/dists/wheezy-updates/Release.gpg Could not resolve ‘ftp.us.debian.org’ W: Failed to fetch http://security.debian.org/dists/wheezy/updates/Release.gpg Could not resolve ‘security.debian.org

Question
-Does it have to do with the beaglebone’s debian’s image not been updated to the latest version?
-Is it because I don’t have complete access to the beaglebone (in reference to the security error message)
-Am I missing some essential packages for the beaglebone?

Would really appreciate your help!

Seems that your BBB has no network (or no nameserver)! Is it connected
via USB only?
Easiest is to connect it via Ethernet to a router with dhcp-Server.

It is connected through Ethernet cable only. I used the SSH root@192.168.7.2 in the Ubuntu terminal to connect to this remote system.

You mean to say that the beagle has no access to the internet? That I need to connect it to a network? How does that work?

do you have a DHCP server on your network ?

where is the BBB getting its address from

if you set up a static address for the BBB you also need to setup the
place where the BBB looks for name resolution

in the file /etc/interface/interfaces it should look like this if you
have a static ip setup

# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.254.205
        netmask 255.255.255.0
        gateway 192.168.254.254

in the file /etc/resolv.conf your name server needs to be there normally
its your gateway

nameserver 192.168.254.254

but it can be googles name servers or a name server of your choice

192.168.7.2 you get usually when connecting over USB. is this a typo?

u said ethernet only

ethernet is dhcp from your router or static ip

Nova Jack,

the nameserver listing in your /etc/resolv.conf file should reflect a valid nameserver for your network. The default value is usually 192.168.1.1.If you do not know what this is, it is normally your internal routers address. You can also use an external nameserver such as 8.8.8.8 or 8.8.4.4.

However the external nameserver IPs I mentioned above belong to google, and typically they like to monitor your every move on the web. Opening sometimes up to 10 connections for whatever reason to a system that uses their nameservers . . .If that is important to you . . .

Also is this a REVC BBB from element14 ? what is the output of the command:

cat /etc/dogtag

Sorry . . . your problem has nothing to do with any of your questions

. Your beaglebone simply can not access the internet. For which there are a few possibilities. The most common problem I’ve seen is resolv.conf’s nameserver attribute being set wrong for the network the BBB is on. But we can get to the other potential problem if / when needed.

Yes. Connected through the Ethernet cable with the computer. Is that wrong to say that this is not the USB port?

192.168.7.2 is the IP address of the Beaglebone Black. That is what I always use to connect the beagle with the computer through ethernet. So what I conclude from your message is that I need to use my internal router’s address to connect to the network?

Yes, it is REV C BBB element 14.

Okay thank you. I guess, I will look into the direction of why it isn’t connecting to the internet. But I haven’t tried to connect it to the internet before. Only my computer. I have been able to connect it with my Linux desktop Ubuntu 14.04. And upload a .cpp file on it. But for the next step, I wanted to try to access the GIOP using Python and Python’s libraries.

Is it a separate step to connect the beagle to the internet when it is connected through the cable with the computer?

*I do apologize for the confusion. I had the misconception that the USB cable is called the ethernet cable.

I always have established a connection between the Beaglebone Black and my computer using the provided USB cable through Remote Server System.

In that case, well either case really. You need to learn about and setup what is known as DNS Masquerading on the Ubuntu host. Something that is fairly complex for a beginner

Something like this:
http://robotic-controls.com/learn/beaglebone/beaglebone-internet-over-usb-only

But you probably only need to use the "on Linux computer " steps. Which would be on your Ubuntu host.