Installing Ubuntu on BB black = Error: no space left on device

Hi,
my BeagleBone Black always gets the same error when installing Ubuntu Desktop: “no space left on device”.
I’m not sure if i do it right.

My Steps:

(1.) downloading ubuntu image named ubuntu-precise-12.04.2-armhf-3.8.13-bone20.img.xz .
(2.) Extracting the file with 7zip.
(3.) Save the system with win32diskimager-binary06 to my 8GB microSD.
(4.) start BB black with microSD.
(5.) login and do “sudo apt-get update” and “sudo apt-get upgrade”.
(6.) after upgrading do “sudo apt-get install ubuntu-dektop”
(7.) after downloaden it sets up some packages…
(8.) while setting up it gets the error “no space left on device”

But there is space, right?
I already tested this: http://superrb.com/blog/2011/10/25/ubuntu-no-space-left-on-device-is-it-a-lie-or-have-i-run-out-of-inodes
It doesen’t work for me…

Is not there an image that include the desktop?
I tested the ubuntu-12.04-preinstalled-desktop-armhf+omap4.img.xz, but if i exctract that i get an RAW-file. O.o

lolxdfly

Did you resize the image? if you go back to the website where you
downloaded it, they talk about it..

Regards,

http://circuitco.com/support/index.php?title=Desktops_On_Ubuntu/Debian

That link should be very helpful. The image you downloaded is supposed to fit on a 2GB card so after it partitions there is only so much space used. If you follow the direction on that page you should have what you want. But I warn you… full Ubuntu desktop is sluggish. I highly suggest the LXDE version ( instructions here: http://circuitco.com/support/index.php?title=Installing_LXDE )

Did you resize the image?

No, i think i dont resized the image. I followed only the steps from top.

if you go back to the website where you
downloaded it, they talk about it…

I downloaded it from here: http://www.armhf.com/index.php/download/
I cant find anything from resizing the image.

Is it required to resize it? If yes, how can i do it?

http://circuitco.com/support/index.php?title=Expanding_File_System_Partition_On_A_microSD

Marcel,

I tried the wiki that Tommy provided and I was able to get it working. It includes the instructions on how to resize it as well.

Thanks for your answers and tips!

I followed the Steps from http://circuitco.com/support/index.php?title=Desktops_On_Ubuntu/Debian !
It work. There were only a few warnings in the installation.

But if i login at the Ubuntu-Loginscreen i get a blackscreen. A few minutes later i see a screen with a cuser and i can move the courser with the mouse. But then, it freeze. The leds on the bord are lighting and of course the power-led. I have tried 3 times but it freeze always after the login :frowning: .

Should i try the LXDE version?

lolxdfly

Oddly, adding a default "xorg.conf" seems to resolve some of the
blinking/freezing issues with 13.04:

http://eewiki.net/display/linuxonarm/BeagleBone+Black#BeagleBoneBlack-HDMI:

Regards,

Which version did you install? Raring or Precise? If you installed Raring try what RobertCNelson suggested. If that doesn’t work I know Ubuntu Desktop works on Precise. LXDE does as well.

sudo apt-get install xserver-xorg-video-modesetting x11-xserver-utils

is installed and actuell!

/etc/X11/xorg.conf

i dont have such a file! Must i create it with the console?

xrandr

it says : “can’t open display”

I found out that it freeze when the cusor spawns. I can move the cursor for some seconds and while moving its blinking.

Which version did you install? Raring or Precise?

I installed Raring.

sudo apt-get install xserver-xorg-video-modesetting x11-xserver-utils

is installed and actuell!

/etc/X11/xorg.conf

i dont have such a file! Must i create it with the console?

Yeap...

xrandr

it says : "can't open display"

scroll down a little farther on that wiki:

xrandr -display :0.0 -q

I found out that it freeze when the cusor spawns. I can move the cursor for
some seconds and while moving its blinking.

Which version did you install? Raring or Precise?

I installed Raring.

Yeap, that needs the xorg.conf... (precise was fine without it..) It
looks like xorg is automaticly defaulting to settings that later cause
lockups on this device.

Regards,

Just ssh in;

sudo nano /etc/X11/xorg.conf

Then just copy/paste from webrowser..

Regards,

I would try adding that file with the contents described at the link Robert mentioned.

My favorite is nano

nano /etc/X11/xorg.conf

<CTRL+x> to save and exit, ‘y’ to confirm write, to finish

I’m in the process of trying this. I’m waiting for Ubuntu Desktop to install.

Thanks Robert,
I hadn’t seen that you replied before I posted.

Or for the really, lazy like me.. :wink:

wget https://raw.github.com/RobertCNelson/tools/master/ubuntu/setup-xorg.sh
chmod +x setup-xorg.sh

./setup-xorg.sh

Regards,

LOL lazy my aaaaa . . .

Seriously Robert you’re doing a wonderful job. Keep it up !

I have done the lazy version and the xrandr-commands. :smiley:

But it doesent fix the freeze. :frowning: It only fixes the blinking.

It's gotta be something in unity/ubuntu then... as it fixes the
freezing with lxde...

Regards,

Thanks for the comment !!!