Invalid Mode Errors When Trying to Configure GPIO

I’m a huge newbie when it comes to the BBB, so bear with me here. Please also forgive me if this isn’t the sort of topic that I ask about here.

I am trying to use the BBB with the PurpleVLC cape in order to perform some VLC research. Unfortunately, I’ve run into some problems getting PurpleVLC to function, and the developers did not have any idea how to fix the problem.

Essentially, I’m following the tutorial listed on the PurpleVLC webpage here.

As part of the tutorial, I reload the pru_rproc, then try to run the repo’s Makefile. When I run the Makefile, it attempts to copy the contents of /config/pru_gpio_config to /dev/null (./config/pru_gpio_config >> /dev/null). When this part of the Makefile runs, however, I get a massive amount of errors related to the pru_gpio_config file, which you can see in the attached picture:


The “: not found” errors seem to pop up whenever the system reads an empty line, but I think the problematic errors are the “invalid mode” errors. And while I’ve tried to find a way to fix these errors, I’m not really finding much. The Universal IO page linked in pru_gpio_config was no help, and blog posts about the PRU and GPIO system aren’t really helping me figure out what’s going on either. I’d like to avoid digging too deep into the BBB documentation if possible since my focus is on an application running on top of the BBB, not the BBB itself.

Does anyone have any idea what exactly is going on and how I could go about addressing this?

Please let me know if you have any further questions. Please also let me know if this is not the right place to post this sort of question, and I’ll delete.