Is my eMMC corrupt? Can I fix it?

Hello there, it’s me again, with problems again. Note: I’ve installed XFCE Desktop version on my BBB’'s eMMC.

I think my eMMC got corrupted when a classmate tried to power a 5" XPT2046 LCD from the BBB’s USB port and then, as the screen was not working, he just unplugged the BBB’s 5V jack instead to hold the power button until shutdown :sweat:

The problem is now, when I try to start the BBB with the LCD screen connected via HDMI (but being the LCD powered by a laptop USB port), all I see is the Linux penguin, and then the BBB shutdowns and restarts, and does this in an infinite loop. The only way I could use it again with the LCD as screen was modifiying the uEnv.txt in the line that says:

#In the event of edid real failures, uncomment this next line:
#cmdline=coherent_pool=1M net.ifnames=0 quiet cape_universal=enable video=HDMI-A-1:1024x768@60e

I had to modify the resolution to 800x480 to match my LCD screen’s resolution.

Then, from so on, every time I want to turn on the BBB and use it with the LCD, I have to:

Unplug everything from the BBB, connect it to a 5V power supply, so it powers in
Wait several minutes and then connect the LCD

Is my eMMC corrupt? Can I fix it?

Best regards,


Why dont you wipe the eMMC content and reinstall the image you like on it and check if that fixed it?