Issues with FTDI cable on Windows with BBB

I have used putty via USB on Windows on BB White without issue for
more than a year. BB White has a FTDI chip.

Now I am trying to use the BB Black with the FTDI cable recommended in
the BBB manual, however it is not working in 95% of my tries. Once it
worked when I had the cable working with Putty in Linux and moved the
cable to the Windows PC. By not working I mean nothing I type gets
displayed, or occasionally only a few garbage characters appear (for
example after I power up the BBB).

I am using the latest FTDI drivers for Windows (32 bits), the latest
version of putty. I have this problem with both Angstrom and Debian on
a BBB rev. B and C. I am configuring putty with 115200 baud. I tried
Tera Term but no luck either. Also tried with and without external
power supply.

On Linux things are well enough with BBB and the FTDI cable (though
not as good as with BBW). I also tried a UART-USB bridge with CP210x
and it is working well enough on BBB in both Windows and Linux.

Any ideas on how to make the recommend FTDI cable work reliably on
Windows with BBB?

I use the FTDI cable for years with no errors at all under Win7 64bits. Usually I use putty but also used Hyper Terminal without issues. You should configure the port 115200 8 bits, no parity

Thanks Maxim. My serial port configuration is the same as yours. I am
using Windows 7 32 bits (for my sins!).

You should go to the FTDI website and download the latest driver.

Thanks. I already did that. Also I tried two different FTDI cables
just in case one was not good.

Are you sure it is a “real” FTDI cable.
There were some cables out there that look the same, but were built with counterfeit FTDI chips.
FTDI released some (Windows) driver updates this past May that could tell them apart, and not work with the counterfeit chips.
They later recalled them, but you may still have them.

— Graham

I confirm what Graham describes. I had issues with custom boards where bought FTDI chips were used, but never with FTDI cables purchased from digikey

Probably what should be done first, is check device manager to make sure the device is actually setup properly. I’ve had Windows change setting on me under device properties at least once. For unknown reasons.

By the way, the prolific pl2303hx cables that cost like 1/10th the price of an FTDI work fine too . . . paid like $2.34 with free shipping.

Hi Graham,

Yes, they are real FTDI cables, I still have the antistatic bags with
the FTDI logo on it.

Hi Williams,

The Device Manager was showing everythin normal, for example when I
plugged the cable a COM port appeared, and when I removed it the COM
port disappeared.

Thanks for the Prolific suggestion.

Ah ! Hibernation has a bad “habit” of causing problems like this.

On the contrary, I have no idea of what the root problem was but
hibernation was part of the (accidental) solution!

On the contrary, I have no idea of what the root problem was but
hibernation was part of the (accidental) solution!

I’ve read a few “stories” of Hibernation causing issues very similar to the one you’ve experienced here. E.G. causing devices to mysteriously go missing, only to reappear at some later date. So, it is my contention that hibernation was the original cause. Maybe true, maybe not, but the problem seems to be solved now.