Jessie Snapshot content

I have the jessie snapshot (10-22) running. Looks good, in general.

The slot manager and device tree files do not seem to be present.
Is this just part of the normal progression of building a new release?

Will they be there for the jessie “freeze” in a few weeks?

— Graham

Nope, you get to do it manually:

sudo apt-get update
sudo apt-get install linux-image-3.8.13-bone67
sudo reboot



On a fresh install of “BBB-eMMC-flasher-debian-jessie-lxqt-armhf-2014-10-22-2gb.img”

Boots clean.

I applied the “install linux-image-3.8.13-bone67” and

I start getting
[FAILED] Failed to start Load Kernel Modules.

systemctl status systemd-modules-load.service sheds no light.

Tried “install udhcpd”

no change.

Tried “apt-get upgrade”

No change.

Any thoughts on how to attack this?


— Graham

Nothing comes to mind, i just did this earlier. The directions i gave
earlier was all you needed todo.



Well, I have done it three times, on two different (stock) RevC hardware sets,
two different clean downloads loads of jessie snapshot 10-22.
Different microSD cards.
jessie is unmodified/untouched in any way, and get the same result…

They boot without error after initial download/install of snapshot 10-22.

Then apply "install linux-image-3.8.13-bone67 " and get

[FAILED] Failed to start Load Kernel Modules.

I am monitoring the command line output on ttyO0.

Debian seems to run fine for my applications, so I do not know which service is

failing to start.

— Graham

Your probally seeing:

debian@beaglebone:~$ systemctl --failed
● dnsmasq.service loaded failed failed dnsmasq - A lightweight DHCP
● systemd-modules-load.service loaded failed failed Load Kernel Modules

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.

2 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

debian@beaglebone:~$ journalctl | grep systemd-modules
Oct 28 15:38:33 beaglebone systemd-modules-load[154]: Module 'fuse' is builtin
Oct 28 15:38:33 beaglebone systemd-modules-load[154]: Failed to find
module 'mt7601Usta'
Oct 28 15:38:33 beaglebone systemd[1]: systemd-modules-load.service:
main process exited, code=exited, status=1/FAILURE
Oct 28 15:38:33 beaglebone systemd[1]: Unit
systemd-modules-load.service entered failed state.

i had the "m7601Usta" module installed for v3.14.x:

remove the old one:

debian@beaglebone:~$ dpkg --list | grep mt7601
ii mt7601u-modules-3.14.22-ti-r31 1jessie
       armhf mt7601u modules

sudo apt-get remove mt7601u-modules-3.14.22-ti-r31 --purge

Install the new one: (if you have the m7601u hardare)

sudo apt-get install mt7601u-modules-`uname -r`
sudo depmod -a `uname -r`
sudo update-initramfs -uk `uname -r`

Or you could just remove:




Removing /etc/modules-load.d/mt7601.conf cured the problem.

Thanks for the quick response.

— Graham