Kernel 3.8.6 modules missing

Hi,

I would like to know if it’s normal and when it will be fixed ? Can I fixe it myself ?

X.Org X Server 1.11.2
Release Date: 2011-11-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.8.3 x86_64
Current Operating System: Linux beaglebone 3.8.6 #1 SMP Sat Apr 13 09:10:52 CEST 2013 armv7l
Kernel command line: console=ttyO0,115200n8 run_hardware_tests quiet root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait
Build Date: 03 April 2013 11:02:53PM

Current version of pixman: 0.27.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Sat Jan 1 04:38:44 2000
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
(EE) Failed to load module “extmod” (module does not exist, 0)
(EE) Failed to load module “dbe” (module does not exist, 0)
(EE) Failed to load module “glx” (module does not exist, 0)
(EE) Failed to load module “record” (module does not exist, 0)
(EE) Failed to load module “dri” (module does not exist, 0)
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

The current directory module :

root@beaglebone:/usr/lib/xorg/modules# ls

drivers input libfb.so libfbdevhw.so libshadow.so libshadowfb.so libvbe.so libvgahw.so

Thx you for your help ,

Ok, I figured out how to install some package, but they are some missing … so my question is : who should I contact ? which mailing list ?

And what is this error I got ? In the previous kernel, it wasn’t there : (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

root@beaglebone:~# opkg install xserver-xorg-extension-extmod xserver-xorg-extension-dbe xserver-xorg-extension-glx xserver-xorg-extension-record xserver-xorg-extension-dri
Package xserver-xorg-extension-extmod (2:1.11.2-r11.10) installed in root is up to date.
Package xserver-xorg-extension-dbe (2:1.11.2-r11.10) installed in root is up to date.
Unknown package ‘xserver-xorg-extension-glx’.
Unknown package ‘xserver-xorg-extension-record’.
Unknown package ‘xserver-xorg-extension-dri’.