Kernel 4.1 rc6-bone6: Ethernet not working

The config file is ok

But I don’t have IP?

eth0 Link encap:Ethernet HWaddr de:ad:be:ef:ca:fe
inet6 addr: fe80::dcad:beff:feef:cafe/64 Scope:Link
UP BROADCAST RUNNING MULTICAST DYNAMIC MTU:1500 Metric:1
RX packets:364 errors:0 dropped:0 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:24543 (23.9 KiB) TX bytes:4365 (4.2 KiB)
Interrupt:174

root@arm:~# dmesg | grep “phy 4a”
[ 6.291037] net eth0: phy 4a101000.mdio:01 not found on slave 1
[ 7.736772] net eth0: phy 4a101000.mdio:01 not found on slave 1

the led orange is ok and led green is blinking which is ok

I tried :

root@arm:~# /etc/init.d/networking restart

[ 185.246094] libphy: PHY 4a101000.mdio:01 not found
[ 185.251107] net eth0: phy 4a101000.mdio:01 not found on slave 1
[ 185.265139] net eth0: BQL enabled
[ 185.275592] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 185.275616] 8021q: adding VLAN 0 to HW filter on device eth0
[ 187.243856] cpsw 4a100000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
[ 187.243961] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

It works :

root@arm:~# ifconfig
eth0 Link encap:Ethernet HWaddr de:ad:be:ef:ca:fe
inet addr:190.190.167.10 Bcast:190.190.255.255 Mask:255.255.0.0
inet6 addr: fe80::dcad:beff:feef:cafe/64 Scope:Link
UP BROADCAST RUNNING MULTICAST DYNAMIC MTU:1500 Metric:1
RX packets:6329 errors:0 dropped:0 overruns:0 frame:0
TX packets:122 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1481867 (1.4 MiB) TX bytes:26160 (25.5 KiB)
Interrupt:174

The entire log of net :

[ 0.090282] Initializing cgroup subsys net_cls
[ 0.090305] Initializing cgroup subsys net_prio
[ 2.794392] audit: initializing netlink subsys (disabled)
[ 2.985118] cpsw 4a100000.ethernet: Detected MACID = 34:b1:f7:1b:02:c2
[ 6.282323] net eth0: initializing cpsw version 1.12 (0)
[ 6.285883] net eth0: phy found : id is : 0x7c0f1
[ 6.291037] net eth0: phy 4a101000.mdio:01 not found on slave 1
[ 6.302341] net eth0: BQL enabled
[ 7.363496] using random self ethernet address
[ 7.363520] using random host ethernet address
[ 7.363532] using host ethernet address: 34:B1:F7:1B:02:C3
[ 7.364433] using random self ethernet address
[ 7.364443] using random host ethernet address
[ 7.364519] g_ether gadget: Ethernet Gadget, version: Memorial Day 2008
[ 7.729161] net eth0: initializing cpsw version 1.12 (0)
[ 7.731536] net eth0: phy found : id is : 0x7c0f1
[ 7.736772] net eth0: phy 4a101000.mdio:01 not found on slave 1
[ 7.816588] net eth0: BQL enabled
[ 8.410985] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 10.803877] cpsw 4a100000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
[ 136.883463] cpsw 4a100000.ethernet eth0: Link is Down
[ 137.883895] cpsw 4a100000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
[ 185.243543] net eth0: initializing cpsw version 1.12 (0)
[ 185.246016] net eth0: phy found : id is : 0x7c0f1
[ 185.251107] net eth0: phy 4a101000.mdio:01 not found on slave 1
[ 185.265139] net eth0: BQL enabled
[ 187.243856] cpsw 4a100000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx

Any idea ?

Ah... It's clearly working..

read: https://wiki.debian.org/NetworkConfiguration

Regards,

I know how to configure IP address:

auto eth0
allow-hotplug eth0
iface eth0 inet static
address 190.190.167.10
netmask 255.255.0.0
gateway 190.190.255.253

But that didn’t work, any idea ? suggestion on where I am wrong ?

Thx,

did you set a name server ?

that ! Ok, No …

nano /etc/resolv.conf

By default I have :

nameserver 127.0.0.1
nameserver ::1

Ok, I will test this with :

nameserver 190.190.1.84

I saved it, reboot the beagle, and the content of the file changed :

Generated by Connection Manager

nameserver 127.0.0.1
nameserver ::1

That my first time that the connection manager in a linux machine change my file !

dns-nameservers 190.190.1.84 >> /etc/network/interfaces

Regards,

I tried on the official Beaglebone black, with the image :

bone-debian-8.0-console-armhf-2015-05-08-2gb.img

the kernel is :

root@arm:~# uname -a
Linux arm 3.14.41-ti-r63 #1 SMP PREEMPT Thu May 7 16:30:13 UTC 2015 armv7l GNU/Linux

eth0 Link encap:Ethernet HWaddr 1c:ba:8c:d9:4c:77
inet6 addr: fe80::1eba:8cff:fed9:4c77/64 Scope:Link
UP BROADCAST RUNNING MULTICAST DYNAMIC MTU:1500 Metric:1
RX packets:475 errors:0 dropped:0 overruns:0 frame:0
TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:30795 (30.0 KiB) TX bytes:5017 (4.8 KiB)
Interrupt:56

still not working, my config :

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

address 190.190.167.10
netmask 255.255.0.0
gateway 190.190.255.253

iface usb0 inet static
address 192.168.7.2
netmask 255.255.255.0
network 192.168.7.0
gateway 192.168.7.1

dns-nameservers 190.190.1.84

any idea ?