kernel comand line parameters

I would like to set the screen resolution for the console and also stop console timeout.

From googling I read that I could change uEnv.txt to the following:

optargs=run_hardware_tests quiet video=omapfb:mode720x480@60 consoleblank=0

but this does not work.

The reason I want to change resolution is that the display goes to 1280x720 resolution when the actual physical resolution is 800x480.
This makes it hard to read text on the console. I don’t know who the manufacturers of these displays is trying to kid!

If I can get 800x480 that would be great, but I would be happy with 720x480. Audio is not used.

edid given below

Many thanks.

root@beaglebone:~# parse-edid /sys/class/drm/card0/card0-HDMI-A-1/edid
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

EDID version 1 revision 3

Section “Monitor”

Block type: 2:0 3:fd

Block type: 2:0 3:fc

Identifier “32V3H-H6A”
VendorName “RTK”
ModelName “32V3H-H6A”

Block type: 2:0 3:fd

HorizSync 24-60
VertRefresh 50-75

Max dot clock (video bandwidth) 110 MHz

Block type: 2:0 3:fc

DPMS capabilities: Active off:no Suspend:no Standby:yes

Mode “1280x720” # vfreq 60.000Hz, hfreq 45.000kHz
DotClock 74.250000
HTimings 1280 1390 1430 1650
VTimings 720 725 730 750
Flags “+HSync” “+VSync”
Mode “720x480” # vfreq 59.940Hz, hfreq 31.469kHz
DotClock 27.000000
HTimings 720 736 798 858
VTimings 480 489 495 525
Flags “-HSync” “-VSync”

Block type: 2:0 3:fd

Block type: 2:0 3:fc


The optargs only work on the initial boot splash screen. I know of no way to force a resolution. I have asked for a way, but have yet to see anything work.


Well based on your video parameter, yes that 'should not' work..

omapfb!=hardware on the bone..

If you want 720x480 use:

and then specify 720x480 in your xorg.conf when using the xorg
modesetting driver..


Or you can also force it to 720x480 via xrandr.. (using the
modesetting driver again)

xrandr --output HDMI-0 --mode 720x480 --rate 60


Thanks for the answers.

I tried video=HDMI-A-1:720x480@60 and just video=640x480@60 and neither worked.

I would like to run without X … just one QT app running, but not being able to set the kernel command line parameters is quite crippling.

Check in /proc/cmdline to make sure your arguments are being passed to
the kernel.

The default Angstrom images have several copies of uEnv.txt floating
around, apparently just to confuse people. :slight_smile:

The uEnv.txt file you need to edit is the one on the FAT file system,
which is the first partition on the eMMC. If you edit one of the
other copies, it won't do anything and your changes won't show up in
/proc/cmdline once booted.

If you see your command line argument in /proc/cmdline and the system
is not behaving the way you want, there is probably something wrong
with the argument you are passing.

- --
Charles Steinkuehler