kernel hangs up after uncompressing linux

Hi,

I am trying to build a new kernel image using arm-none-linux-gnueabi-
toolchain. I built the Linux Kernel 2.6.32 , after this i formatted
and created partitions in my
SD Card wherein i copied the uImage into the first partition of the SD
Card. Now when i bootup the board, then during the time of starting
kernel, i get the following
message:

## Booting kernel from Legacy Image at 80200000 ...

   Image Name: Linux-2.6.32.9-g049a746-dirty

   Image Type: ARM Linux Kernel Image (uncompressed)

   Data Size: 1919772 Bytes = 1.8 MB

   Load Address: 00008000

   Entry Point: 00008000

   Verifying Checksum ... OK

   Loading Kernel Image ... OK

  OK

  Starting Kernel .........

  Uncompressing
Linux .........................................................................

  .............................................................done,
booting the kernel.

  after this is hangs

  Thanks and regards

  Ravi

Could you send your bootargs? It may caused by bootargs.

Regards,
Yan

the serial output has changed from ttyS to ttyO in the recent
kernels..
Change it in uboot..

Not exactly in u-boot, but in bootargs. Probably you can change it in boot.scr.

Thank you,
Johnson

It may be due to DefConfig file selected during the kernel build process…I also faced the same,plz follow the following link:
http://groups.google.com/group/beagleboard/browse_thread/thread/c8a342126783a96e/f36bbf9772bc3676?hl=en&lnk=gst&q=Kernel+Hangs+while+starting#f36bbf9772bc3676

Danke,
Rajiv.

To be precise, it is ttyO2, instead of ttyS2.

Thank you,
Johnson