kernel panic loading firmware from SD-card

I am getting a kernel panic when I try to load firmware from an SD-card. I have tried several different images. Any suggestions what else I can try?
Here is the console output:
Begin: Running /scripts/local-bottom … done.
Begin: Running /scripts/init-bottom … done.
[ 120.521745] INFO: task mmcqd/0:71 blocked for more than 60 seconds.
[ 120.530919] “echo 0 > /proc/sys/kernel/hung_task_timeout_secs” disables this message.
[ 120.541666] mmcqd/0 D c04d04a5 0 71 2 0x00000000
[ 120.550934] Kernel panic - not syncing: hung_task: blocked tasks
[ 120.559813] [] (unwind_backtrace+0x1/0x9c) from [] (panic+0x59/0x15c)
[ 120.571000] [] (panic+0x59/0x15c) from [] (watchdog+0x19d/0x1c0)
[ 120.581792] [] (watchdog+0x19d/0x1c0) from [] (kthread+0x6b/0x78)
[ 120.592698] [] (kthread+0x6b/0x78) from [] (ret_from_fork+0x11/0x34)
[ 120.603876] drm_kms_helper: panic occurred, switching back to text console

This is an issue with 3.8.x..

Try "any" other manufacture's microSD card and a good known 5volt dc
power supply.

Later kernels (such as 3.14.x) handle this much better..


I have tried both Kingston and sandisk SD-cards. And i Am using a 1 amp 5 volt wall wart.


i had this issue and used


with no issues since

The problem I can’t load any code at all onto it. So how di I get 3.14.x onto it>


I think we should start over. Tell us the exact details, starting from where you began. Which image, how you got it to which flash media, board version. etc.

I have tried the latest debian and a special audio image from computer audio. I load the images onto an SD-card. I insert my sd-card into my neagle board. I then hold down S2 while powering up my board. It starts to boot and and then it panics.

This is on the console:

Just use one of the jessie images here:

which default to 3.14.x, then if you need 3.8.x just downgrade thru apt-get:

sudo apt-get update
sudo apt-get install linux-image-3.8.13-bone71
sudo reboot


That is one of the images I have tried to load. It panics when I try to load any image.

from that you are trying to flash the Emmc not boot off of the SD card
so you are using the flasher image
if you desire to just boot off the SD card try a non flasher image
load to SD card and it should boot



Have you tried just using a standalone image on an sdcard to see if that works. Based on your console output above you’re trying to flash the eMMC. Your board also seems to be a RevC

I’ll try it next and see where is gets me. Thanks.



Does your latest flasher image still use a two partition layout ? He’s showing two partitions on both mmc devices . . .

Yes it does. This is the one from computer-audio

when replying to these mails please don't erase all the previous reply's
makes it very hard to follow

Yes it does. This is the one from computer-audio

This image you’re trying to use from computer-audio, whoever that is. You should be contacting them, asking for help.

Here, we know the official images, and try to support them the best we can. In my case, I’m not involved with building the actual official images for But I do build my own images, and have a couple years experience with my own, and the official images. In short, I know many things, and try to help.

However, without being involved in the process of building these other images. There is no way we can tell what they’ve done, and by extension what is wrong with those images. It may be possible if you provided us with very detailed information we ight be able to help. But I’ve yet to see this . . .

It is not an image issue. It load fine on another board. I guess this board is broken