Keyboard on the Rev C2 USB host port

Hi,

First of all, nice to be here. I just received my beagleboard and I am
very happy with it. I bought a powered USB hub and I installed it
using the USB host port. I downloaded the demo image and it boots
fine. However, I can't get past the "enter new user" dialog as the
keyboard and mouse are not recognized.

How do I enable the use of HID compliant devices on the USB host port?
Do I need to have a specific kernel? I am just trying to invent how to
compile the kernel, so if anyone has a prebaked one that would be
nice, or do I need to do something with u-boot?

Hope anyone can help. I can't wait to try OE.

Kind regards,

Eelco Rouw
The Netherlands

Mouse works for me. I don't recall having to do anything special.
I also have kbd issues, but only with X11, not with the cmd line.

Btw you can check whether cmd line works by taking your card to
another computer then comment starting gde-dm within /ettc/update-rc.d
(thanks to Koen for this suggestion).

FM

In the validation image (http://code.google.com/p/beagleboard/wiki/BeagleboardRevCValidation
) has instructions for checking out the mouse and keyboard using
'evtest' so you can be confident it isn't a hardware problem. Try
those steps and report back.

Thankfully the problem has been solved by the help of Sakoman. He
pointed out that my u-boot and x-loader were outdated and I used an
old kernel.

I downloaded the latest packages from Sakoman and voila, the mouse and
keyboard worked flawlessly!

Now I only have to find out why my DVI cable worked with my monitor
and not with my LCD tv (out of the box I saw the beagleboard logo on
the TV, so it should work).

Kind regards!

Eelco

Thankfully the problem has been solved by the help of Sakoman. He
pointed out that my u-boot and x-loader were outdated and I used an
old kernel.

I downloaded the latest packages from Sakoman and voila, the mouse and
keyboard worked flawlessly!

Now I only have to find out why my DVI cable worked with my monitor
and not with my LCD tv (out of the box I saw the beagleboard logo on
the TV, so it should work).

That will be a timings/resolution issue. See http://elinux.org/BeagleBoardFAQ#Display_resolutions_.231
.