latest Angstrom beaglebone img not booting

Has anyone booted the latest Angstrom distribution beaglebone img? The original img works fine but the new one stalls while booting:

Starting kernel …

Uncompressing Linux… done, booting the kernel.
[ 0.224426] _omap_mux_get_by_name: Could not find signal leds-gpio
[ 0.525054] omap_hwmod: wkup_m3: wkup_m3: hwmod data error: OMAP4 does not support st_shift

The file I’m using is:

Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.05-beaglebone-2012.04.22.img

same problem

step1 - check md5sum

root@silver:~/Project/Images# md5sum Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.05-beaglebone-2012.04.22.img.xz
5a4e6b1dc66acc553f3bee43ee1fa062 Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.05-beaglebone-2012.04.22.img.xz

it is good

Thanks but, step1 was done before posting here. That’s not it.

It looks like the problem is with the 3.2.14 kernel. If you try to boot that kernel from the original image, you get the same problem. Booting the 3.2.5+ kernel works. It also looks like that line of code should not be hit on the beagleboard CPU.

sorry I’m new to this…
I’m running ths image without issue
Angstrom-Cloud9-IDE-eglibc-ipk-v2012.04-core-beaglebone-2012.04.09.img
root@beaglebone:~# uname -a
Linux beaglebone 3.2.14 #1 Mon Apr 9 12:21:19 CEST 2012 armv7l GNU/Linux

I just compiled the newest angstrom build…it is also 3.2.14.
I’m just trying to build an image with wifi that boots and works…
Are you using the mainline 3.2.5 kernel?

I’m just using what came on the stock image. It boots to 3.2.5+ but if you place the included 3.2.14 kernel in the boot partition and use it, it freezes just like the newer Angstrom download image (which only has 3.2.14).

I burned the previous image and it boots with 3.2.14 kernel as well. It is just the latest image on the Angstrom download site that is bad. I guess nobody has tried to use it since it was posted.

yep…

Booting the previous image works but once an opkg update/upgrade is done it fails in the same spot as the new Angstrom image. It looks like the current kernel is broken for the beaglebone.

I have built a new kernel today and still no success…

USB power or DC jack?

DC jack

Did you update files MLO/u-boot.img and uImage at /boot partition?
if not, the board may not be booted.

I’m booting the distribution image, not a hand built one.

Give http://dominion.thruhere.net/koen/angstrom/beaglebone/Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.05-beaglebone-2012.05.09.img.xz a try

That works, thanks!

BTW, bison and flex are still broken with the hardcoded paths in the binaries.

much better thnx