Latest angstrom image not very fast x.x !

Hello all :slight_smile: !

Just been trying out the latest angstrom beaglebone black image ( ) but I’ve been noticing a couple of problems. First of all though (hurrah!) I did manage finally to get a display from my beaglebone black and the latest angstrom image; previous to this the only one that had worked is the older version on the beaglebone black’s internal storage.

I managed to get it going by (after some research) looking up EDIDs. I copied off the edid file from the older (working) angstrom image on the internal storage, copied it over to a normal desktop PC and ran parse-edid on it. If it helps btw heres my xorg.conf;

Section “Module”
Load “extmod”
Load “dbe”
Load “glx”
Load “freetype”
Load “type1”
Load “record”
Load “dri”

#Section “Monitor”

Identifier “Builtin Default Monitor”


Section “Monitor”

Block type: 2:0 3:fc

Identifier “HDMI to VGA”
VendorName “EXP”
ModelName “HDMI to VGA”

Block type: 2:0 3:fc

Block type: 2:0 3:fd

HorizSync 31-83
VertRefresh 56-76

Max dot clock (video bandwidth) 180 MHz

DPMS capabilities: Active off:yes Suspend:no Standby:no

Mode “1024x768” # vfreq 60.004Hz, hfreq 48.363kHz
DotClock 65.000000
HTimings 1024 1048 1184 1344
VTimings 768 771 777 806
Mode “1280x720” # vfreq 60.000Hz, hfreq 45.000kHz
DotClock 74.250000
HTimings 1280 1390 1430 1650
VTimings 720 725 730 750
Flags “+HSync” “+VSync”

Block type: 2:0 3:fc

Block type: 2:0 3:fd


Section “Device”
Identifier “Builtin Default fbdev Device 0”
Driver “modesetting”

Section “Screen”
Identifier “Builtin Default fbdev Screen 0”
Device “Builtin Default fbdev Device 0”
Monitor “HDMI to VGA”
DefaultDepth 16

Section “ServerLayout”
Identifier “Builtin Default Layout”
Screen “Builtin Default fbdev Screen 0”

Might work/help out someone else out there with a VGA to HDMI converter!

There’s just one problem though. It feels almost as if my beaglebone black with the latest angstrom image is almost running as if it were only operating at half speed! The old angstrom on the internal storage - loaded up fast even firefox. The latest version (I should point out, prehaps this is the root cause of my problem though I am not sure - the newer image is being run from a micro SD card) seems very slow - in fact I tried to load the GIMP and the beagleboard hung!

Could it be I possibly have the slowest micro sd card in the universe or maybe there’s something else going wrong?


Not sure, but you are providing the microSD card, so it could be a slow one. Most likely made for a camera optimized for fast writes and not fast reads. any reason why you can’t try it on the emMC and see how it responds?


Would give it a try on the emmc – only reason I didn’t is because I just wanted to make sure I had some sort of “fallback” system to have about just in case everything went wrong. Though I’d need to somehow modify xorg.conf (as above) before I flash to emmc otherwise I’d have no display!


Well the good news - I eventually remanaged to get a newer install into the emmc and it does feel faster.

But programs still seem to crash a lot. Firefox will barely load :frowning: . or just crashes. The gimp also died and just stopped x.x

I also tried a larger power supply just to make sure that wasn’t the issue but it didn’t help.