LCD4/LCD7/4DCAPE-43 Backlight PWM - Changing Frequency


The PWM for the backlight which controls the LCD4 / LCD7 / 4DCAPE-43, is this controlled from the Kernel for from the dts file located in /lib/firmware/ ?

I have tried to edit the dts file in /lib/firmware/ and edited the PWM frequency to be 200Hz from the standard 2Khz, and compiled the dts file into the dtbo file, however it wasn’t picked up on next reboot.

I am just learning this stuff so I don’t really know what I am missing.

Someone told me that the ‘standard capes’ may be controlled from the kernel rather than from the dts files in the /lib/firmware/ folder, and the /lib/firmware/ folder isnt even mounted at the point the kernel version kicks in.
Is this true?

If it is, does it require a kernel rebuild in order to change something like the PWM frequency?
Is it possible to apply a patch or something rather than having to rebuild the kernel? If so, how is this done?

I even went to the extent of changing the EEPROM content of one of the CAPES I have, and then edited a dts file with the same name and part number inside, and then tried to force the cape to be loaded after it had started up by using the uEnv.txt, but that didn’t work either.

I am stumped.

I am just wanting a quick fix to do some testing.

Please if anyone could help I would really appreciate it.


More learning

I Think I managed to rebuild the kernel using the 3.8 source and info from here:
changing the dts files in the kernel before the rebuild.
But now I am stuck as to how to get the new kernel onto the BBB

Is the only method with TFTP via the serial cable?
Or is it possible to do via the uSD card?

Running Angstrom on the eMMC currently.



Rebuilt kernel as default capes like the LCD4 and LCD7 are controlled by dts files inside the kernel, not from the ones found in the /lib/firmware/ folder.
Loaded onto the BBB over ethernet
Works as desired.

Bizzare how no one on this forum could help me.
Think its time to join another forum.


You might be misunderstanding how 'forums' work...

I have been been dealing with exactly the same issue, after spending a couple of days i have manged to get the kernel booting the tftp server. Hvae you managed to get the image onto an sdcard so the kernel will boot with the need for the tftp server.