LCD7 doesn't work on latest debian lxqt image

bone-debian-8.6-lxqt-4gb-armhf-2016-11-06-4gb.img on a beaglebone white:

the same lcd7 cape that worked in older kernels is absolutely dead

At power on , on old kernels TUX penguin appears before booting up, with last image, display is black from start.

Old Kernel :

root@arm:~# cat /sys/devices/bone_capemgr.8/slots
0: 54:P—L BeagleBone LCD7 CAPE,00A2,Beagleboardtoys,BB-BONE-LCD7-01
1: 55:PF—
2: 56:PF—
3: 57:PF—

New one:

root@beaglebone:~# cat /sys/devices/platform/bone_capemgr/slots
0: P—L- 0 BeagleBone LCD7 CAPE,00A2,Beagleboardtoys,BB-BONE-LCD7-01
1: PF---- -1
2: PF---- -1
3: PF---- -1

Display is detected ,anyway

Played for long time with uEnv.txt with no results…

Any suggestion please ??

dtb=am335x-boneblack-overlay.dtb

display is black till drm/tilcd comes up.. video is very racy,
planning to shove all the lcd capes into u-boot..

Regards,

Robert,
Uncommented #dtb=am335x-boneblack-overlay.dtb line on /boot/uEnv.txt
Same behaviour, screen dead
LCD is a 5,7" LCD7 clone, always worked in previous kernels recognized as LCD7 cape (as SLOTS says)
BeagleBone is a white one : any difference ?

Not an expert, any value/config to check on old working microSD ??

Thank you

Please test:

https://github.com/beagleboard/bb.org-overlays/commit/d4b0ba69d7ba6cfb80d5288faea2991af7dfff6f

(i could never find an A2 on ebay, on my A3 lcd this was just working)

this repo is in our default image, so just:

cd /opt/source/bb.org-overlays/
git pull
sudo ./install.sh

reboot

Regards,