libsoc 0.4: SPI support

libsoc 0.4 has been released. As before, please let me know if you feel it is missing features, or you come across any bugs.

https://github.com/jackmitch/libsoc

06/10/13 - 0.4