Linksys USB200M doesn't work

Hello Beagle Boarders,

  I'm trying to get the Linksys USB200M working and wondered if anyone
knows the right tricks. I can plug this same adapter into my host
Debian box and it works perfectly.

  I'm tried:

ifconfig usb0 hw ether 00:10:60:85:95:98
ifconfig usb0 192.168.1.25 up
mkdir -p /usr/share/udhcpc
echo "#!/bin/sh" > /usr/share/udhcpc/default.script
chmod 755 /usr/share/udhcpc/default.script
udhcpc -i usb0&

  I'm using uImage_OTG and rd-ext2-8M.bin:

[root@beagleboard /]# uname -
a
Linux beagleboard.org 2.6.22.18-omap3 #1 Thu Jul 24 15:29:36 IST 2008
armv7l unk
nown

[root@beagleboard /]#
ifconfig
usb0 Link encap:Ethernet HWaddr
00:10:60:85:95:98
          inet addr:192.168.1.25 Bcast:192.168.1.255 Mask:
255.255.255.0
          UP BROADCAST MULTICAST MTU:1500 Metric:
1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:
0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:
0
          collisions:0 txqueuelen:
1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

I don't get any errors from the above but nothing works:

[root@beagleboard /]# ping
192.168.1.1
PING 192.168.1.1 (192.168.1.1): 56 data
bytes
[hangs]

  Any help greatly appreciated!

  Rick

Are you connecting the USB200M to the board directly?

I tried USB100M talking to the board through a USB hub (the USB hub has its own power supply)
and it works.

This way the beagle board is not the power source.

Thanks much for the reply. Actually I am hooking it directly to the
Beagleboard. The only hub I have at the moment is an old USB 1.1, do
you think that will work?

  Rick

Hello,

I have 2 USB 1.1 hub both not work with beagle, 2.0 hub work very well.
I think 100mA from beagle may not enough for WIFI usb.

Network device name usb0 may be USB network gadget. try to cat
/proc/bus/usb/device and ifconfig -a to see your network device name (eth1 ?).

Nathanan.

2008/8/19, rickbronson@gmail.com <rickbronson@gmail.com>:

EMBES_Nathanan Srisa-ard wrote:

Hello,

I have 2 USB 1.1 hub both not work with beagle, 2.0 hub work very well.
I think 100mA from beagle may not enough for WIFI usb.

Network device name usb0 may be USB network gadget. try to cat
/proc/bus/usb/device and ifconfig -a to see your network device name (eth1
?).

I recall reading somewhere that the only way to connect a non-USB 2.0 device to
the Beagleboard was through a self-powered, USB 2.0-compliant hub. IIRC, the
reason was because the USBH on the Beagleboard was currently 2.0-only.

b.g.

That was for the host-only port that is not on the Rev B boards. I
believe the OTG port can handle full-speed as well as high-speed
devices.

If you are connecting a hub, it *does* need to be self-powered as no
hub is specified to work at only 100mA since it must also power a
target device. As you mention, I believe the boards will only supply
100mA and only if it ID-pin selected.

Thanks for all of the help!

  Okay, I've got a 4 port hub that claims to be 2.0, it shows up on my
host as:

Bus 001 Device 024: ID 0409:005a NEC Corp.

  But when I plug the USB200M into the beagleboard with the power
adapter connected, I do get usb0 to show up but no lights come on on
the USB200M

[root@beagleboard /dev]# ifconfig -
a
lo Link encap:Local
Loopback
          LOOPBACK MTU:16436 Metric:
1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:
0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:
0
          collisions:0 txqueuelen:
0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0
B)

usb0 Link encap:Ethernet HWaddr
92:3B:B2:1B:E4:03
          BROADCAST MULTICAST MTU:1500 Metric:
1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:
0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:
0
          collisions:0 txqueuelen:
1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0
B)

[root@beagleboard /dev]# cat /proc/bus/usb/
devices
cat: can't open '/proc/bus/usb/devices': No such file or
directory

  When I plug in the USB200M directly I get the same as above but the
2 of the lights come on.

  Ok, I'm starting to wonder if I'm using the right kernel:

[root@beagleboard /dev]# uname -
a
Linux beagleboard.org 2.6.22.18-omap3 #1 Thu Jul 24 15:29:36 IST 2008
armv7l unk
nown

  which I got from http://beagleboard.googlecode.com/files/uImage_OTG

  Anyone?

  Thanks again for all the help.

  Rick

rickbronson@gmail.com wrote:

  Ok, I'm starting to wonder if I'm using the right kernel:

[root@beagleboard /dev]# uname -
a
Linux beagleboard.org 2.6.22.18-omap3 #1 Thu Jul 24 15:29:36 IST 2008
armv7l unk
nown

  which I got from http://beagleboard.googlecode.com/files/uImage_OTG

  Anyone?

Do you have a kernel from that vintage on a different ARM platform? Does that
kernel work with the ethernet controller?

b.g.

May be support for your Ethernet dongle is not enabled in Kernel, You
can just check what driver is needed for this particular version of
hardware from Windows or a Linux Host machine.

Regards
Khasim

Build kernel with support for RTL8150 based ethernet adapter.
Device Drivers → Network Device support → USB Network adapters → USB RTL8150 based ethernet device support

Best regards
Sandeep

Finally got it to work by using the uImage and filesystem in
http://www.angstrom-distribution.org/demo/beagleboard/
Apparently it doesn't work with http://beagleboard.googlecode.com/files/uImage_OTG

  Thanks for all the help!

  Rick

Just when I thought everything was working fine...

  I'm getting these pretty often when the USB200M is connected to the
HOST port:

1-0:1.0: port 1 disabled by hub (EMI?), re-
enabling...
usb 1-1: USB disconnect, address
2
eth0: unregister 'asix' usb-ehci-omap.0-1, ASIX AX8817x USB 2.0
Ethernet
hub 1-0:1.0: unable to enumerate USB device on port 1

  I get them even when I don't have a powered hub connected (ie. the
USB200M is directly plugged into the HOST port.

  Anyone else seen this problem?

  Thanks,

  Rick

Can you try by putting nohz=off at the end of your bootargs.

Regards,
Khasim

Khasim,
  I tried the nohz option and it does seem to work better but if I
wait a long time while pinging the beagleboard it dies with the same
message. If I ftp a file it dies right away.

  Thanks for the help!

  Rick

rickbronson@gmail.com wrote:

Khasim,
  I tried the nohz option and it does seem to work better but if I
wait a long time while pinging the beagleboard it dies with the same
message. If I ftp a file it dies right away.

Could this be related:

I had trouble with USB dropping out until I applied that patch. It doesn't
look like it's made it into the git tree yet.