loading i2c tools on to the beagle board to work with dlp pico projector

Hello sir,

I installed the latest angstrom demo image on beagleboard rev C4 using
SD card. Logged in as root. Pico projector is connected to HDMI port
and shows the login screen. I have a serial port connected with tera
term pro and a mouse and keyboard connected to beagleboard. I can play
the included BigBunny movie on pico projector.

Now to work with dlp pico projector i2c commands have need to be passed. For that i2c tools are required.

My questions are

  1. Does i2c drivers already written on beagle board?

  2. If it is yes for the above question, how to load i2c tools which are on my SD card in to the beagle board ?


root@beagleboard:/dev# uname -a

when I run this “uname -a” command iam getting as

Linux beagleboard 2.6.28-omap1 #2 Thu Feb 19 12:45:34 IST 2009 armv7l

I mean it is not showing that i2c bus 1,2,3 exists.

so, please help me out in knowing wether i2c drivers exists or not and if so what is the procedure to access i2c bus-3 on beagleboard to configure the dlp pico projector.

thank you in advance.

i2c works on my BB running kernel 2.6.32.

I think it works with .28 also.

I can dump the EDID from my monitor using

i2cdump -y 0x3 0x50 b

But I don't read anything from the pico projector. Maybe its EEPROM is
empty, or had a different address, or maybe it just don't have it.

Marco Casaroli

hello sir,

i have downloaded i2c-tools-3.0.2.tar.bz2 from http://www.lm-sensors.org/wiki/I2CTools.

I tried to compile the i2c tools using arm cross compiler. I have done the following steps.

#mkdir /data
#cp -av /media/KINGSTON/arm-2009q1-203-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2 /data/
#cp -av /media/KINGSTON/i2c-tools-3.0.2.tar.bz2 /data
#cd /data
#tar -xvf arm-2009q1-203-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
#tar -xvf i2c-tools-3.0.2.tar.bz2
#cd i2c-tools-3.0.2
#make cc=/data/arm-2009q1 prefix=/media/LABEL2 (SD Card root file system)
#make cc=/data/arm-2009q1 prefix=/media/LABEL2 install

I couldnot the binary file for i2cbusses.c.when i put the SD card containing these folders in the beagle board, I should be able execute the i2c commands.the execution of commands giving errors.iam unable to activate the bus3-i2c.

beagleboard login: root
root@beagleboard:~# cd /media/mmcblk0p2
root@beagleboard:/media/mmcblk0p2# ls
bin include lost+found sbin share
root@beagleboard:/media/mmcblk0p2# cd sbin/
root@beagleboard:/media/mmcblk0p2/sbin# ls
i2c-stub-from-dump i2cdump i2cset
i2cdetect i2cget
root@beagleboard:/media/mmcblk0p2/sbin# i2cdetect -l
i2cdetect: line 1: syntax error: “(” unexpected

please help me in loading the tools into to the board and get the i2c commands executed. tell me anywhere if i have gone wrong in doing the above commands.

thank you.


I am trying to integrate touch panel onto I2C in beagle board but my I2C is not working.Iam not able to get any signals on the I2C pins on expansion connector of beagle board.
Can anyone tell me what might be the issue.

I met the same error [syntax error: “(” unexpected"]. I modified the Make file then it works.

(original, beware of the question mark)
CC ?= gcc


pragnya lakshmi於 2011年10月30日星期日UTC+8下午11時24分33秒寫道: