LXQT autostart problem

Hello,

I have a strange LXQT autostart problem. I have 4 BBB’s all running the latest image (Debian 9.5). My python application runs fine on all of them (from QTerminal). On two of these systems I can make LXQT-Autostart my application work (LXQT settings-Session settings-Application Autostart, under LXQT Autostart). On the other two nothing runs automatically. The .desktop files are all the same, their names as well. I tried everything I could think of, I even re-installed the image. No luck. This already took me days. Please help me out or give me a pointer where to look.
Thanks a lot.
Harke .

Hello,

Seth here, again. Are you running your board(s) w/ SD Card or on the eMMC of the BBBs? I know this is happening over and over again but my ideas remain the same. Try to, if you are using SD Card, update your eMMC or erase the contents of the eMMC.

U-Boot overlays need to be updated. If you are using the eMMC on all the BBBs, I will think of something else.

Seth

P.S. Please list the info. from this command: sudo ./version.sh | grep bootloader. First apply a git pull in /opt/scripts/tools/developers/ directory. For each board, please reply w/ the version of your bootloader. You can label them 1. to 4. w/ the relevant info.

Hello Seth,

Thanks for coming back to me, again.
All systems work with flashed os. No SD card inserted.
This from a non working system:

Last login: Thu Feb 7 11:18:52 2019 from 2001:982:c7c1:1:48cb:8340:1675:32fa
debian@beaglebone:~$ sudo /opt/scripts/tools/version.sh
[sudo] password for debian:
git:/opt/scripts/:[974401727fdcbd58751bd99456a7baa6bd6891a0]
eeprom:[A335BNLT00C02916BBBK1556]
model:[TI_AM335x_BeagleBone_Black]
dogtag:[BeagleBoard.org Debian Image 2018-10-07]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-g0b54a51eee]:[l ocation: dd MBR]
kernel:[4.14.71-ti-r80]
nodejs:[v6.14.4]
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/AM335X-PRU-RPROC-4-14-TI- 00A0.dtbo]
uboot_overlay_options:[enable_uboot_cape_universal=1]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.4.20181106.0-0rcnee0~stretch+20181110]
pkg:[bb-wl18xx-firmware]:[1.20180517-0rcnee0~stretch+20180517]
pkg:[kmod]:[23-2rcnee1~stretch+20171005]
pkg:[librobotcontrol]:[1.0.4-git20181108.0-0rcnee0~stretch+20181110]
pkg:[firmware-ti-connectivity]:[20170823-1rcnee1~stretch+20180328]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev us ers systemd-journal i2c bluetooth netdev cloud9ide gpio pwm eqep admin spi tisdk weston-launch xenomai]
cmdline:[console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/m mcblk1p1 ro rootfstype=ext4 rootwait uboot_detected_capes=BB-BONE-LCD4-01, coher ent_pool=1M net.ifnames=0 quiet]
dmesg | grep pinctrl-single
[ 1.130498] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568
dmesg | grep gpio-of-helper
[ 1.142379] gpio-of-helper ocp:cape-universal: ready
END

I did perform the github comand.

This is from a working system:

debian@beaglebone:~$ sudo /opt/scripts/tools/version.sh
[sudo] password for debian:
git:/opt/scripts/:[1aa73453b2c980b75e31e83dab7dd8b6696f10c7]
eeprom:[A335BNLT00C00816BBBK0459]
model:[TI_AM335x_BeagleBone_Black]
dogtag:[BeagleBoard.org Debian Image 2018-10-07]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-g0b54a51eee]:[location: dd MBR]
kernel:[4.14.71-ti-r80]
nodejs:[v6.14.4]
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_addr4=/lib/firmware/BB-I2C1-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/AM335X-PRU-RPROC-4-14-TI-00A0.dtbo]
uboot_overlay_options:[enable_uboot_cape_universal=1]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.4.20181120.0-0rcnee0~stretch+20181120]
pkg:[bb-wl18xx-firmware]:[1.20180517-0rcnee0~stretch+20180517]
pkg:[kmod]:[23-2rcnee1~stretch+20171005]
pkg:[librobotcontrol]:[1.0.4-git20181108.0-0rcnee0~stretch+20181110]
pkg:[firmware-ti-connectivity]:[20170823-1rcnee1~stretch+20180328]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c bluetooth netdev cloud9ide gpio pwm eqep admin spi tisdk weston-launch xenomai]
cmdline:[console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait uboot_detected_capes=BB-BONE-LCD4-01,BBORG_MOTOR, coherent_pool=1M net.ifnames=0 quiet]
dmesg | grep pinctrl-single
[ 1.132913] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568
[ 1.601249] pinctrl-single 44e10800.pinmux: pin PIN19 already requested by 48302200.pwm; cannot claim for gpio_keys
[ 1.612024] pinctrl-single 44e10800.pinmux: pin-19 (gpio_keys) status -22
[ 1.619036] pinctrl-single 44e10800.pinmux: could not request pin 19 (PIN19) from group pinmux_bb_lcd_keymap_pins on device pinctrl-single
dmesg | grep gpio-of-helper
[ 1.144987] gpio-of-helper ocp:cape-universal: ready
END
debian@beaglebone:~$

I hope two examples are enough for the diagnosis. A third ystem, working good, is gone with his owner, who needed it obviously. The systems are not 100% identical, but my knowledge of Debion/BBB is too limited to understand its implications.
Many thanks in advance,
Harke

Hello Harke,

Seth here. I see that you have a .dtbo file in the BBB that does work.

See line on the broken config. from above: uboot_overlay_options:[uboot_overlay_addr4=/lib/firmware/BB-I2C1-00A0.dtbo]

If you are messing w/ overlays instead of managing the config-pin utility. This may prove valuable.

Seth

P.S. Try adding this device tree blob object file to your boards that do not work. If I am correct, the .dtbo file is the only difference in those two ./version.sh cmds listed.

Hello Seth,

Thanks for coming back to me. I am definitively no expert in this field but I guess I see what you mean. The dtbo refered to deals with i2c-1. I assumed as in the past I need i2c-1 to enable the RTC. It turns out not to be and with respect to my LXQT problem can be ignored, I think. Now I have the rtc enabled on i2c-2, more or less… (I hate changing these things without good docs…). Please correct me if I am wrong.

I guess its something in the LXQT shell that works differently.
Cheers,
H

Hello and Okay…

Harke! I think i2c1 is taken up by the Cape functionality of the boards. Did you change that or something or are you now using the i2c2?

Seth

P.S. Either way, the LXQT issue is still here, right? So, w/out further wait…I think that this was solved a while back. Let me ruffle the pages and search some in the history of the googlegroups. I should be able to find something at some point.

What about the .profile entries?

Seth

Hi Seth,

Yes, the autorun problem is still there.
Going from old Debian releases to the latest one (9.5) gave me a couple of surprises. My Python application proved to be portable but a lot needed to be modified. One was the repacement of i2c-1 by i2c-2, while i2c-1 was no longer accessible, by default. It took a while to understand what was going on. I opened a topic elsewhere on this site but no response… Then I applied the latest Adafruit rtc recipe (adapted for i2c-2!) and could make the rtc work, in a way. I even managed to make a rtc installation service work! Though the learning curve is steep at times, I am still no expert and I doubt that the i2c issues has an influence on the aurorun problem.
I am not familiar with .profile entries.
Thanks (again) for your efforts, Seth!
Cheers,
H

Yea. Harke,

Hello…I think you need to update the entire image if you want to work w/ a fixed/new bugs in the kernel. Anyway: https://wiki.qt.io/BeagleBone_Black_Beginners_Guide. That guide is something I found locally on this wiki/group.

Seth

P.S. I know that you are having trouble w/ the .service file for starting services on boot w/ QT. Do you have your .service file or a rendition?

Hello Seth, and others interested,

Yes the .service file for the rtc works fine.
But my LXQT Autostart problem is getting strange. I have three versions of basically the same Python script. V 3.6: using digital I/O bits. V4.6 and V5.6 use two pwm bits as well. And guess what: only V3.6 starts automatically (on the same system) via Autostart. I can manually start the other versions without any errors whatsoever. I tried different pwm pins, no success. On another system v4.6 starts in autostart.

Its really puzzling. And taking a lot of time.
Will resume later unless you have a brilliant idea?
Best regards,
Harke