machinekit on BBB - how to force enabled HDMI hardware from cmdline

I’m getting going with LinuxCNC Machinekit on BBB but my first hiccup is that I can’t get HDMI hardware enabled. I have an HDMI-DVI cable and for whatever reason the hardware has to be told to turn on. With Angstrom I pass “video=HDMI-A-1:e” on optargs in uEnv.txt but default Debian in Machinekit doesn’t do it.

is there something I can do to force it on/enabled from the command line? I’ve tried shelling in with ssh -X then doing xrandr :0.0 --output HDMI1 --auto but it didn’t work.
I’m checking /sys/class/drm/card0-HDMI-A-1/enabled and when booting Angstrom without a display connected it states “enabled” as it should. Booting Machinekit it states “disabled”.

any ideas? Thanks.


First, are you sure the option is being passed to the kernel? What does
"cat /proc/cmdline" return?

Second, have you tried the 'e' flag while also specifying a resolution?
Try something like:

kms_force_mode=video=HDMI-A-1:1024x768@60e /boot/uboot/uEnv.txt.

I had looked at it and overlooked what was the problem but you asking and my copy/paste made me realize I’d cat’ed it onto the capemgr.disable… mesg with a comma instead of separating it. It now works. Thanks for slap in the back of the head.


HI Doug
I’m running into the same problem here using beagleboard black running ubuntu-dsktop on a sd card the /sys/class/drm/card0-HDMI-A-1/enabled shows disabled
cat /proc/cmdline shows this

console=ttyO0,115200n8 video capemgr=capemgr.enable_partno=BB-BONELT-HDMI root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait

ubuntu@ubuntu-armhf:~$ cat /sys/devices/bone_capemgr.9/slots
0: 54:PF—
1: 55:PF—
2: 56:PF—
3: 57:PF—
4: ff:P-O-L Bone-LT-eMMC-2G,00A0,Texas Instrument,BB-BONE-EMMC-2G
5: ff:P-O-L Bone-Black-HDMI,00A0,Texas Instrument,BB-BONELT-HDMI

can u show me your uenv file? thx i try to edit my uenv doesn’t work

in the uEnv.txt file there’s a line starting with “optargs=”
Add to the end of that line:

" video=HDMI-A-1:e"

make sure there’s a space before the “video=…” and this should force the enabling of the HDMI port.


Thanks for the quick reply doug
i tried
optargs=fixrtc video=HDMI-A-1:e
uenvcmd=i2c mw 0x24 1 0x3e; kd=0; if test $mmcdev -eq 1; then mmc dev 0; if mmc$
loadfdt=load mmc ${mmcdev}:${mmcpart} ${fdtaddr} ${bootdir}/dtbs/${fdtfile}
loadimage=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${bootdir}/${bootfile}

and some other things still not working any other suggestions or did i did it wrong? thanks a lot

I tried
optargs=fixrtc video=HDMI-A-1:e capemgr.enable_partno=BB-BONELT-HDMI #importent change the line above
uenvcmd=i2c mw 0x24 1 0x3e; kd=0; if test $mmcdev -eq 1; then mmc dev 0; if mmc$
loadfdt=load mmc ${mmcdev}:${mmcpart} ${fdtaddr} ${bootdir}/dtbs/${fdtfile}
loadimage=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${bootdir}/${bootfile}

and it worked thanks
best jason

great to hear it works