Making a change to the device tree, the right way?

Backstory: been working on getting both LEDscape (uses the PRUSS) and SDcard hotplug to work. LEDscape (GitHub - Yona-Appletree/LEDscape: Beagle Bone Black cape and firmware for driving a large number of WS281x LED strips.) asks you to install a custom device tree blob. I did so, and I noticed that my SDcard stopped working. I decompiled both dtb’s and compared them, finding one salient difference:

pruss@4a300000 {

compatible = “ti,pruss-v2”;

ti,hwmods = “pruss”;

ti,deassert-hard-reset = “pruss”, “pruss”;

reg = <0x4a300000 0x80000>;

ti,pintc-offset = <0x20000>;

interrupt-parent = <0x1>;

status = “okay”;

interrupts = <0x14 0x15 0x16 0x17 0x18 0x19 0x1a 0x1b>;

linux,phandle = <0x34>;

phandle = <0x34>;

};

In the Beaglebone device tree pruss@4a300000 status is set to ‘disabled’ and on the LEDscape version it’s set to OK. I made the change and LEDscape works! But I don’t think running my own custom device tree sounds like fun. So I’m wondering:

  1. Should the default just be ‘okay’? Guessing no, but I’d like to know why.

  2. Is there another way to change this setting during runtime, and should LEDscape be doing that instead of installing a custom dtb? Like altering /proc?

  3. Is there a way for me to override the the dtb for just this one setting, instead of replace the file.

Thanks for all your help so far + big ups to Robert Nelson, Debian on BBB has come a long way.