Mamona on beagle

Hello,

I try to use Mamona on my beagle. I took the omap3430 image. It boots fine, X11 comes up. But then I get a screen to calibrate my touchpad. I do not have a touchpad. How can I get a real login screen? I searched through the /etc-directory of the mamona directory and did not find the place where the calibration is started.

Robert

Hi Robert,

    You should remove 30xTs_Calibrate.

mamona > rm etc/X11/Xsession.d/30xTs_Calibrate

I guess it can help you.

Regards,
Alecrim.

Hi Alecrim,

that worked. Now I am not able to use my mouse with X. I tried as an option for Xfbdev:
-mouse /dev/input/mice
-mouse /dev/input/event0
-mouse /dev/psaux

I tested the mouse with
cat /dev/input/mice
and it worked.

How can I use my mouse?

Bye - Robert

2008/10/1 Keppler Alecrim <alecrim@gmail.com>

Hi Robert,

    I'll check it and answer you ASAP.

Bye,
Alecrim.

Hi Robert,

    You should change
mamona.git/packages/xorg-xserver/xserver-kdrive_1.4.bb as [1], rebuild
this package and upgrade your rootfs. This will make mouse cursor
visible.

    I guess you still have xserver working, if not add a few lines [2]
to etc/X11/Xserver. As you can see it uses -mouse mouse instead of
-mouse tslib.

I guess it can help you. :slight_smile:

Cheers,
Alecrim.

[1] - >

diff --git a/packages/xorg-xserver/xserver-kdrive_1.4.bb
b/packages/xorg-xserver/xserver-kdrive_1.4.bb
index fca2dca..fb4140a 100644
--- a/packages/xorg-xserver/xserver-kdrive_1.4.bb
+++ b/packages/xorg-xserver/xserver-kdrive_1.4.bb
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
DEPENDS += "hal libxkbfile libxcalibrate pixman"

PE = "1"
-PR = "r3"
+PR = "r4"

SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
   ${KDRIVE_COMMON_PATCHES} \
@@ -29,4 +29,4 @@ S = "${WORKDIR}/xorg-server-${PV}"
W100_OECONF = "--disable-w100"
W100_OECONF_arm = "--enable-w100"

-EXTRA_OECONF += "--enable-builtin-fonts --enable-null-root-cursor"
+EXTRA_OECONF += "--enable-builtin-fonts"

[2] ----->

"OMAP3 Beagle board")
           ARGS="$ARGS -screen ${SCREEN_SIZE} -mouse mouse -nolisten tcp" ;;

He Alecrim,

I will give it a try - thank you!

Robert

2008/10/3 Keppler Alecrim <alecrim@gmail.com>