max310x & spi patch


On my board we use pins of uart0 for the spi interface ( all others pins are used ) .

To do so, we deactivate the max310x by default, but when the linux boot, it has to move a gpio to enable the device. I modified the spi driver to detect the parameter : enable-gpio = <&gpio1 3 GPIO_ACTIVE_LOW>;

also we used the max310x with an external clock, so we don’t need a clock node. To do so, I modified the driver max310x to detect the parameter: clock-frequency = <1843200>; .

And it works well !

the patch :

From 50358ac2b1daad3850e57caca85390dc39186da5 Mon Sep 17 00:00:00 2001