Mesh on BBBW

I am trying to setup the BBB Wireless for mesh functionality, however i noticed that all the files for the wilink 8 required are not even built.

I am doing the tutorial from

http://www.ti.com/lit/an/swaa166/swaa166.pdf

and realise that the files are missing from

/usr/share/wl18xx/

can anyone please advise on how to proceed thanks.

i’ve tried to build the wilink8 using

http://processors.wiki.ti.com/index.php/WiLink8_Linux_Getting_Started_Guide

but it is really complex and there are tons of errors on the way, has anyone succesfully build it?

Hi Benjamin,

First some background before we go into the details.

There are two types of wilink8 driver deliveries

  • TI driver release. R8.7 is the latest. This is the full feature driver release that includes all features including mesh. It is built via the build script at the link you mentioned. It uses backports to build the driver source (in a 4.4.8 kernel) against your kernel.
  • mainline (K4.1 and above). This is a subset of the TI driver release including the standard features accepted by the community as non-proprietary. Mesh comes into this category which is why you don’t see it. The mainline driver was mostly R8.6 - the full list of differences between mainline and R8.6 is at http://processors.wiki.ti.com/index.php/WiLink8_Release_Notes/R8.6#Change_log_from_mainline_versions . I’m not sure if there is any plan to push mesh to mainline.

And now to your question.
The build script is quite simple to use as long as the setup-env file points to your toolchain, kernel and filesystem.
The only problem you may be facing is that if your kernel is newer than 4.4.8 then the build may fail as backport will have nothing to do as it was designed to work back to older kernels.

If you paste your build error I may be able to identify if it is a setup-env problem which should be simple to fix.

Iain

A follow up on this one.

Iain

Yes I meant BBBW. You should use the open source kernel device tree as the basis.

If you are building the TI SDK then you can use the Makefile in the base directory of Processor SDK3 to build only the dtb files. You will need to add the dts file name you have added for the BBBW to the linux-dtbs rule in the Makefile. Then run:

make linux-dtbs

Iain

Hi Iain

I’m trying to configure ad-hoc mode on BBBW, and I am follow instructions http://processors.wiki.ti.com/index.php/WiLink8_Linux_Getting_Started_Guide and here http://www.ti.com/lit/an/swaa166/swaa166.pdf too.

I solved many problem on the way, but I reached a point that I get this error:

Hi Jose,

I’ve never used the build script with compat/backports on a 4.4 kernel. Only suggestion I can make is to work out what the actual build error is. Ie why is there a problem here

/home/sensorfield/wl8-build/build-utilites/src/compat_wireless/compat/backport-4.4.c: In function ‘backport_tso_build_hdr’:

/home/sensorfield/wl8-build/build-utilites/src/compat_wireless/compat/backport-4.4.c:103:6: error: dereferencing pointer to incomplete type

It may be a change that occurred at some point in 4.4.x that the backports you are using is not providing a solution for.

Iain