Microsoft Keyboard not recognized ...

I am running on Angstrom distro 2013-06-20 and as soon as I plug in the Microsoft Keyboard (Natural Ergonmic 4000) this is not recognized. Power is available, cause the Num-Lock lights, but the keys not. I tried as well to change the keyboard-layout, but no success.

Any hints, what to do? Is there a chance to get it working in another distro?

You have to plug it in before you apply power. I have yet to find a Microsoft keyboard that doe snot work.


Doesn’t help, I cannot even turn on/off the NumLock-keys.

Please note: I can plug and unplug a Mouse without a problem while BBB is running as well as some other keyboard (Speedlink).

Any more ideas?


A list of keyboards that are known to work can be found at

Sounds like maybe the one you have may need a driver. Have you tried using a USB HUB?


I tried both, direct and via hub, no difference.

Is it a limitation of Angstrom or of the BBB?


It is the kernel. All the other keyboards work, So I see no reason to believe it is the board design itself. It is possible that you board may have a USB issue. You can request an RMA and have it looked at.


The upcoming -bone27 kernel has a bunch of new HID drivers enabled that
might be relevant:

In particular, it looks like CONFIG_HID_MICROSOFT has not been enabled
prior to the -bone26.1 and -bone27 kernels.

You can download the new kernel from RCN's site, but you'll have to
install it manually:

Thx. for the last udpate. I have some questions left:

  1. You mention, that some options were not enabled prior to -bone27 kernels. But the links you provided for the RCN side provides only 27 kernels. So is there a 28 kernel around or is it just mere wording mislead?

  2. Since there are several files, I don’t completely understand what to do with them resp. How to install them? Just download all files, upload them to SD-card. launch BeagleBoard with the latest Amstrong version and execute to the Or what kind of procedure is thought about?

I tried Microsoft keyboard now as well on the Ubutunu 13.04, but it doesn’t work there neither. Since its the only keyboard NOT working, I wonder where the limitation is. Since it occurs on Ubuntu as well, I would guess, that kernel issues might be ruled out. And just returning the device as RMA with the pure hope on another BBB it would work seems quite low cause other keyboards work. But anyway I’ll give it a chance, if I would know how to apply the new kernel.


Update to the 09.04 release

Just update to the latest angstrom release and don't use any of those scripts, they won't work.

Hm’, sorry, but now I am completely confused. Looking on the image site I see only 06.20. On the rcn site I see only files <=15MB, which I guess is far too small for a complete Amstrong-Linux-image. Would you mind to provide a link to download 09.04?

Not sure where you are looking.

It clearly states:

  1. Download the image file of choice by clicking on the links below and saving it to a directory of choice on your PC. ALL images are eMMC flasher images that will flash the eMMC. They are not images to be used to boot from the uSD expecting a desktop or anything close to a good experience. They are for flashing only. They do contain on them an image that is flashed onto the eMMC during the flashing process.


Thx the 09.04 image fix the issue and now its working - GREAT :slight_smile:

Have you looked at the angstrom site: ? That always has the latest builds, per definition :slight_smile: