Minicom showing unreadable characters when connected and booting with BBB using FTDI usb-serail

I’m using minicom in ubuntu host to see the logs in boot time of BBB.
Minicom is set with following configuration,

Serial dev : ttyUSB0
Lock file : /var/lock
Bps/par/bits : 115200 8N1
H/W flow cntrl : no
S/W flow cntrl : no

Minicom opens up and when BBB boots it shows unreadable characters!
Did I miss any other config to be made ? pls help!


Double check with gtkterm, if it's still corrupted, invest in a
usb-serial adapter that isn't less then $1...


I Tried with gtkterm in ubuntu & putty in windows. Got same result. May be I should buy a new usb-serial.


Also test the usb cable/hub/connector..


The prolific pl2303hx cables work good too. If you’re in the market for a new one. Just saw one on newegg for $1.57 . . . but does not say what TTL voltage is. Not sure if all 2303HX cables are 3v3 logic or not. But the ones we got off ebay several month ago were 3v3, and were less than $3 each. They’re still working great.