Missing /lib/modules/4.19.8-armv7-x11

I have BBB with 4GB eMMC. I successfully installed Ubuntu 18.04 using “BBB-eMMC-flasher-ubuntu-18.04.1-console-armhf-2018-12-10-2gb.img.xz” Then I attempted to install LXDE with the following result:
“depmod: ERROR: could not open directory /lib/modules/4.19.8-armv7-x11: No such file or directory”
with several other related messages following.

Results of version.sh–

ubuntu@arm:/opt/scripts/tools$ sudo ./version.sh
git:/opt/scripts/:[d9a7ff1063db8359841c0349caf0898fd0bbc452]
eeprom:[A335BNLT00C04718BBBK1E85]
model:[TI_AM335x_BeagleBone_Black]
dogtag:[rcn-ee.net console Ubuntu Image 2018-12-10]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-gd5b4c4b656]:[location: dd MBR]
kernel:[4.14.79-ti-r84]
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/AM335X-PRU-UIO-00A0.dtbo]
uboot_overlay_options:[enable_uboot_cape_universal=1]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.4.20181120.0-0rcnee0~bionic+20181120]
pkg:[bb-wl18xx-firmware]:[1.20180517-0rcnee0~bionic+20180517]
pkg:[kmod]:[24-1ubuntu3.1rcnee0~bionic+20181120]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
groups:[ubuntu : ubuntu adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal bluetooth netdev i2c gpio pwm eqep admin spi tisdk weston-launch xenomai cloud9ide]
cmdline:[console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 quiet cape_universal=enable]
dmesg | grep pinctrl-single
[ 1.270880] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568
dmesg | grep gpio-of-helper
[ 1.282537] gpio-of-helper ocp:cape-universal: ready
END

Any suggestions?
Thank you,
Gary Rogers

I haven’t tried to do what you’re asking, but the error message suggests it wants a 4.19 kernel while you have a 4.14 one installed. There are instructions on elixir how to upgrade kernels or you could see if there’s an older version of lxde available which doesn’t need 4.19. Or I’m completely mistaken, but there’s an idea for you.

Jim