mjpg streamer problem

Anyone else faced up with a problem like this one?

I’m using a BBB rev C with Debian, image 3.8.13-bone70, with a Microsoft® LifeCam HD-3000 directly connected to BBB USB port and streaming to my LAN via ethernet cable.

this is the result of v4l2-ctl

v4l2-ctl --all

Driver Info (not using libv4l2):

Driver name : uvcvideo

Card type : Microsoft® LifeCam HD-3000

Bus info : usb-musb-hdrc.1.auto-1

Driver version: 3.8.13

Capabilities : 0x84000001

Video Capture

Streaming

Format Video Capture:

Width/Height : 1280/720

Pixel Format : ‘MJPG’

Field : None

Bytes per Line: 0

Size Image : 1843200

Colorspace : SRGB

Crop Capability Video Capture:

Bounds : Left 0, Top 0, Width 1280, Height 720

Default : Left 0, Top 0, Width 1280, Height 720

Pixel Aspect: 1/1

Video input : 0 (Camera 1: ok)

Streaming Parameters Video Capture:

Capabilities : timeperframe

Frames per second: 7.500 (15/2)

Read buffers : 0

Priority: 2

Launching mjpg_streamer with this command:
/usr/local/bin/mjpg_streamer -i “/usr/local/lib/input_uvc.so -n -f 5 -r 1280x720” -o “/usr/local/lib/output_http.so -w /usr/local/www”

it starts fine with a regular output:

MJPG Streamer Version: svn rev:

i: Using V4L2 device.: /dev/video0

i: Desired Resolution: 1280 x 720

i: Frames Per Second.: 5

i: Format…: MJPEG

o: www-folder-path…: /usr/local/www/

o: HTTP TCP port…: 8080

but very frequently it stops with this error:

*** glibc detected *** /usr/local/bin/mjpg_streamer: double free or corruption (fasttop): 0x00015690 ***

Aborted

any idea?

thank you in advance.

A little update.

Connecting to the video stream with Chrome (OS X 10.10.2), it’s stable since more than 24 hours. Connecting via Safari, mjpg_streamer crashes randomly after some minutes or some hours.

I’m using the mjpg_streamer version already installed in image 3.8.13-bone70.

Could I try compiling it with different switches and upgrading all the dependencies?