mkcard.txt problem

hi everybody....

i am trying to use "mkcard.txt" file present on the main download site
to format the sd card and prepare dual partition on sd card.

i copied the file into my home directory.and use

"source mkcard.txt" to execute, but after execution, it displayed

adnan@ubuntu:~$ source mkcard.txt
dd: opening `': No such file or directory
DISK SIZE - bytes
(standard_in) 1: syntax error
sfdisk: option requires an argument -- 'C'
sfdisk (util-linux-ng 2.16)
Usage: sfdisk [options] device ...
device: something like /dev/hda or /dev/sda
useful options:
    -s [or --show-size]: list size of a partition
    -c [or --id]: print or change partition Id
    -l [or --list]: list partitions of each device
    -d [or --dump]: idem, but in a format suitable for later
    -i [or --increment]: number cylinders etc. from 1 instead of from
    -uS, -uB, -uC, -uM: accept/report in units of sectors/blocks/
    -T [or --list-types]:list the known partition types
    -D [or --DOS]: for DOS-compatibility: waste a little space
    -R [or --re-read]: make kernel reread partition table
    -N# : change only the partition with number #
    -n : do not actually write to disk
    -O file : save the sectors that will be overwritten to
    -I file : restore these sectors again
    -v [or --version]: print version
    -? [or --help]: print this message
dangerous options:
    -g [or --show-geometry]: print the kernel's idea of the geometry
    -G [or --show-pt-geometry]: print geometry guessed from the
partition table
    -x [or --show-extended]: also list extended partitions on output
                             or expect descriptors for them on input
    -L [or --Linux]: do not complain about things irrelevant for
    -q [or --quiet]: suppress warning messages
    You can override the detected geometry using:
    -C# [or --cylinders #]:set the number of cylinders to use
    -H# [or --heads #]: set the number of heads to use
    -S# [or --sectors #]: set the number of sectors to use
You can disable all consistency checking with:
    -f [or --force]: do what I say, even if it is stupid
Cant find boot partition in /dev
Cant find rootfs partition in /de

Does anybody have an idea whats wrong ?
Thanks in anticipation.


I think you’ve executed incorrectly.

You should chmod +x mkcard.txt

Then, run it ./mkcard.txt /dev/mmcblk0


Rename mkcard.txt to You have to call mkcard with flash
card device as parameter.
sh ./ /dev/sdz

where sdz od the device for the destination drive.


Thanks alot Jacek and John :slight_smile:
I tried with "sh ./ /dev/sdz" and it worked.
this community has been really helpful.