mmcinit --> "No MMC Card found"

Hi everybody,

I just tried to get my new Beagleboard to work. Following the
instructions in I have built
myself an SD card with Ubuntu but using the mmcinit command in U-Boot
leads to the error message "No MMC card found". I also tried a card
which came with the board with the same results. Is there a
possibility that the card slot is defective or is it a software issue?

Thanks in advance!


I've seen this happen before, usually it's a corrupt file system on the mmc card

Check your card with : "sudo fdisk -l" are the partitions listed correctly?

Next, when you rebuild the mmc card, use the 'sync' command to flush
the kernel buffers to ensure everything is written the mmc card.


If you spend a lot of time ejecting and inserting SD cards you’ll soon come across the “sync” is asynchronous feature of linux. Suffice to say its very annoying and at times leads to corrupt filesystems even after you’ve sync’ed a couple of times and waited for a couple of seconds…

I’m old skool and always thought that the “eject” command was only for CD-ROMs… turns out its for pendrives and SD cards too…

So… don’t “sudo sync” but rather “sudo eject something” where something is either the mount point, the partition dev file (e.g. /dev/sdd2) or the actual device (e.g. /dev/sdd). When the “eject” command returns the drive can be removed immediately without fear of corruption… :slight_smile:

I have attatched the messages from my beagle below. I am wondering why
I get the messages "Loading u-boot.bin from nand" even if I have
pressed the USER button. Should the Beagle in this case not at least
try to read the MMC card? I have also run the fsinfo command which
leads to an error message (see below).

My partitions look correct:
   Gerät boot. Anfang Ende Blöcke Id System
/dev/sde1 * 1 6 48163+ b W95 FAT32
/dev/sde2 7 489 3879697+ 83 Linux

Holding the USER button changes where the bootrom tried to find X-Loader. The boot order is normally NAND,USB,SERIAL,MMC and with USER pressed it becomes USB,SERIAL,MMC,NAND… if the first three options don’t work out then the bootrom will eventually boot from NAND again.

Its worth pointing out that this is where X-Loader is loaded from. X-Loader could be compiled to use NAND rather than MMC so its worth checking you’ve got the right version on your SD card.

This is what I get:

$ sudo fdisk -l /dev/sdd
Disk /dev/sdd: 2032 MB, 2032664576 bytes
255 heads, 63 sectors/track, 247 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdd1 * 1 14 112423+ c W95 FAT32 (LBA)
/dev/sdd2 15 247 1871572+ 83 Linux

Your first parition has an ID of ‘b’ rather than ‘c’. You might also need to change the drive’s geometry, see:

Ok, I have rebuilt the Card according to your guide, it now looks like

Platte /dev/sde: 4029 MByte, 4029677568 Byte
255 Köpfe, 63 Sektoren/Spuren, 489 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x0008f324

   Gerät boot. Anfang Ende Blöcke Id System
/dev/sde1 * 1 51 409626 c W95 FAT32
/dev/sde2 52 489 3518235 83 Linux

I've used MLO, uImage.bin and u-boot.bin from but still get the
"No mmc card found" message when I enter mmcinit and the board skips
straigt to booting from nand.

Hmm… either the SD connector is broken (seems a lot of that around at the moment :slight_smile: or the SD card simply isn’t compatible with the BeagleBoard… Your 8Gb card should be fine… provided its SDHC and not SDXC (I’ve been happily using a 16Gb SHDC card)

I’d have to assume the connector is broken.

Hang on… misread your output… you’ve got a 4Gb card…
Its a bit hot here today so brain has gone to mush…

Is your first parition around 400Mb…? That might be a problem for the bootrom… Most people have a primary partition of 50Mb which is usually ample, perhaps it being so large is the problem…??? (I think the Google code instructions should say +50M for the partition size rather than 50 cyclinders…!!)

Go get the ESC demo image from

dd() from the image to the card

Give it a try and report back...

- dan

I was thinking the same thing, however using a 400Mb partition on my
4Gb Transcend card works just fine on my beagle b5 with U-Boot
2009.3/2009.6-rc2... X-loader 1.4.2...

Disk /dev/sdd: 4029 MB, 4029677568 bytes
255 heads, 63 sectors/track, 489 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000ba161

   Device Boot Start End Blocks Id System
/dev/sdd1 1 51 409626 b W95 FAT32