Module installed failed on beagle board

For my research, I have to use the beagle board to implement a
wireless environment with Linux kernel.

Due to my USB wireless card is a RT73 chip device, I got the reference
link witch support
rt73 image to implement OS system onto SD/MMC card.

Unfortunately, it can not work on my beagle board. The OS worked fine
but the wireless card was not active.

    Image : uImage-2.6.26-r64-beagleboard.bin
    Root file system : Angstrom-Beagleboard-demo-image-glibc-

I think I should used the correct image and file system. (the same
kernel version between both)
However the module installation is still failed.
Does anyone please give me some suggestion how to install rt73usb
module into demo image?

Few related message as below:

Try with modprobe --force-modversion it worked for the powervr
drivers. I don't know exactly why, probably two different builds of
the same kernel source got mixed, but there are modules that does not
match exactly the kernel module version.



rt2x00# insmod rt73usb.ko
rt73usb: disagrees about version of symbol struct_module
insmod: error inserting 'rt73usb.ko': -1 Invalid module

says your module is from a different version.
Guess you are using a module that does not fit with your kernel.


Hi guys,

My issues solved.
Latest Angstrom image had built in rt73 module.
The root cause make the device not worked is the bagleboard usb port
did not support enough power.

Thanks your helps.