monitor fb (flickering and resolution) on ubuntu 13.10 vs 14.04

dear BBB users—I searched for ubuntu 14.04 but did not find anything related to this question. (it may be related to the uEnv.txt EDID question I posted earlier, but maybe not.)

I have two BBB, one running ubuntu 13.10, the other running 14.04.1. the 13.10 distro produces a rock-solid text display on two different monitors. the 14.04.1 is subtly flickering on both. I believe both boot into the linux framebuffer, not a graphical environment (so no X and xrandr).

both are right now connected to an asus vs229 monitor. it is a 1920x1080 full HD monitor. the reason why I suspect this is a beaglebone issue is that the same weird issue has also occurred on a DELL monitor. solid on 13.10, flicker on 14.04:

ubuntu 13.10 ubuntu-armhf: the asus monitor tells me it selects a mode of 1680x1050 65KHz 60Hz. (solid)

ubuntu 14.04.1 LTS arm: the asus monitor tells me it selects a mode of 1280x1024 64KHz 60Hz. (flicker)

apparently, the command to control the linux framebuffer is fbset. by itself, it tells me the current resolution. (there is no edid or resolution info in /var/log/syslog as far as I can tell.) this is working.

changing the framebuffer resolution is another matter, though.

fbset -xres 1920 -yres 1080 tells me that this is an ioctl FBIOPUT_VSCREENINFO: Invalid argument. choosing a smaller resolution, like fbset -xres 640 -yres 480 leaves the current screen-res, but just displays on the top, so it does not really change the resolution at run-time.

are there any ways to change the BBB resolution at run-time?

/iaw

PS: (interestingly, X is not included in the images, although the distro only uses about 370MB of 2GB or eMMC. I am not complaining—thanks to whoever packaged it, of course.)

At boot . . .

https://groups.google.com/forum/#!searchin/beagleboard/Robert|sort:date/beagleboard/Nb5TQxykUo4/9MIJYFQB43YJ

Note the cmdline=video= comment by Robert. However, as with anything Linux, it is very important that you do not put your hardware into a mode it can not handle. SO make sure you know what you’re doing before you make this change.

As for X not being installed, judging by the size of your image, it sounds like you installed a console image. Which in my own option means you can install LXDE manually ( or x-manager of choice ). Again, in my opinion is better than starting with the LXDE image which is loaded / bloated with software.

Robert also has an image resize script somewhere on those images, assuming you’re using a bb.org testing / official image. Somewhere, but I do not know much about it, I use nfs root, and do all my own resizing manually using dd and / or tar.

Are the /etc/fb.mode files the same on both versions?

don’t know. but, because I decided to abandon ubuntu and switch to debian (the official distro of good beagleboards everywhere), it’s become unimportant for me. I couldn’t even check, because I flashed the eMMC in those BBBs already. the latest debians seem fine.

/iaw