Mono on last debian

Hi, any hint how to install mono in the last debian image? (I need this because a little touchscreen, very jittery in angstrom)

I get:

root@beaglebone:/# apt-get install mono-runtime
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mono-runtime:armel : Depends: mono-gac:armel (= but it is not installable
Recommends: binfmt-support:armel (>= 1.1.2)
E: Unable to correct problems, you have held broken packages.

And something similar for mono-complete.



With build instructions here:

We are using this with RCN’s Ubuntu. Last built it many months ago though and are considering that version stable for our purposes, so can’t speak to any recent changes or updates.

Thanks, I will try in Ubuntu too (because the touchscreen maybe it works in there)

OK, I tried in ubuntu and since it runs slow, I just switched back. Here is how it worked in my BBB (or How to get mono in the Beaglebone Black):

  1. Configure the SD!category-topic/beagleboard/support/-I08ZxSpau8

  2. Change dir to the SD, run
    git clone git://

  3. sudo apt-get install automake
    sudo apt-get install libtool
    sudo apt-get install gettext
    sudo apt-get install libgdiplus
    sudo apt-get install pkg-config

  4. ./ --prefix=/usr/local
    …wait few minutes…

  5. make get-monolite-latest

  6. make EXTERNAL_MCS=${PWD}/mcs/class/lib/monolite/gmcs.exe
    …wait few hours…

  7. make install
    …wait about an hour…

Mono should be running by now, check that:

root@beaglebone:/home/debian/Desktop/test# mono --version
Mono JIT compiler version 3.4.1 (master/02b95e9 Sat Mar 29 01:45:18 UTC 2014)
Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors.
TLS: __thread
SIGSEGV: normal
Notifications: epoll
Architecture: armel,vfp+hard
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen

And compiling something:

  1. nano test.cs

  2. Type/paste the code below*

  3. mcs test.cs

  4. mono test.exe

  5. Profit!

using System;

internal class Program
private static void Main()
var d = DateTime.Now.AddSeconds(1); // Just to test Hard-float stuff
Console.WriteLine(“Mono reporting for duty at {0}”, d);


And last little thing:
ln -s /usr/lib/ /usr/local/lib/

Not sure why but mono complains for that lib :stuck_out_tongue:

Probably because GDI+ is the graphic interface built into the .NET BCL. Although, aside from you pulling in the whole System namespace, I do not understand why it would complain either. Unless it is somehow required for Console.Writeline() for some odd reason. Which very well may be if you’re running this app from X.

Correct, this was later building a complete winforms app with xbuild :slight_smile:

Well,. glad to see you got it working for yourself. I was wanting to get this working myself last June but noted that the mono runtimes for ARM were rather limited. I’ve since made the choice to use Nodejs instead. Which for me makes sense because I plan on making a Linux appliance out of the BBB anyway.

Good job.

Yeah, but you can’t really code normally without Resharper+VS2013 (intellitrace, unit tests, profiling, refactoring, linq, etc are so pleasant!) after using those once, and since it runs so well in the RPI, then I wanted to run the same little apps here.

I made a deb with checkinstall, not sure how it works but here it is:

“tried in ubuntu and since it runs slow, I just switched back”

How much slower was Ubuntu compared to Debian?

And do you have any insights as to what the issues/differences were?


Well in debian my bbb starts in about 18 secs and it is very snappy. In ubuntu was very laggy to do anything. Not sure why but I just played about 10 minutes and decided to go back (I am using a small touch cape, so maybe the experience was worse than normal because the small screen).

Differences besides the speed I noticed: Debian does not allow me to switch usb dongles without restarting, and the touch sensitivity was screwed in ubuntu.

It works. Thanks a lot for saving ‘make’ time. :wink: